1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

Alarm keeps going off. Help!!

Discussion in 'Engine' started by maestegman, Jun 3, 2011.

  1. maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    The list of issues with my 03 W211 E270 continues . . .

    The newest member of the niggle club is the alarm. It goes off at unexpected times and, once started, I can't do anything to stop it. Then, after about 10 minutes, it disengages.

    Any ideas?

    BTW, add this to: my groaning steering, squeaking brakes, whirring wheels, windy windscreen, etc., etc.

    I love Mercs me . . .
     
  2. mafya

    mafya Hardcore MB Enthusiast

    Messages:
    102
    Joined:
    May 22, 2011
    Location:
    Sheffield
    Car:
    mercedes e270cdi w211

    I had this issue on my 53 w211 e270 a bit back, i also sometimes got the consumers electricals temporarily switched off message after start up.
    I changed my battery for a Bosch silverline one and the alarm problem never returned.
     
    1 person likes this.
  3. OP
    OP
    maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    Thanks Mafya. More cost again then. Any idea how much a new battery is going to set me back?
     
    Last edited: Jun 4, 2011
  4. Justin1600

    Justin1600 Hardcore MB Enthusiast

    Messages:
    2,073
    Joined:
    Dec 28, 2010
    Car:
    C43 AMG

    Approx £130 for a good one :thumb:

    Could be the alarm siren ;)
     
    1 person likes this.
  5. OP
    OP
    maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    Thanks Justin.

    I swore after buying my last MB (a C220 CDi Coupe) that I would never buy another one due to the fact that everything went wrong.

    Now, after 3 months of owning my E270, I'm starting to wonder why I did it again.

    Is it just me or does everything that goes wrong with a Merc not appear on a warranty?!
     
  6. mafya

    mafya Hardcore MB Enthusiast

    Messages:
    102
    Joined:
    May 22, 2011
    Location:
    Sheffield
    Car:
    mercedes e270cdi w211

    I got a Bosch silverline 100ma one with 5yrs warranty from halfords for £129.00.
     
  7. mafya

    mafya Hardcore MB Enthusiast

    Messages:
    102
    Joined:
    May 22, 2011
    Location:
    Sheffield
    Car:
    mercedes e270cdi w211

    Have you read my thread about the problems mine is giving me?
     
    1 person likes this.
  8. A210AMG

    A210AMG Hardcore MB Enthusiast

    Messages:
    8,475
    Joined:
    Mar 15, 2007
    Location:
    England
    Hello its an 03 car probably original battery? Batterys go in any car, any equivalent battery in an e class type car would cost the same....

    As it happens my car did the same a few time but it was down to short trips then weeks without being used.

    I try to use it at least once a week on a good run and no issues so far :)
     
    1 person likes this.
  9. voy2age

    voy2age Hardcore MB Enthusiast

    Messages:
    139
    Joined:
    Sep 30, 2010
    Location:
    france
    Car:
    C220 coupe
    i had the same problem on my C220 CDI coupe 2003, it went off on a sunny hot day and after a few clicks on the key (opening the doors, etc) it was ok. i thought it may have been a fly inside the car setting the sensor off, then a few later the indicators started to flash,but no siren, i have now removed the siren (which has sorted the problem) i'll wait until i get a cheap one off ebay. just thought this may be the start to the problem i had or maybe there is no link.. hope this helps.. just a thought
     
    1 person likes this.
  10. Justin1600

    Justin1600 Hardcore MB Enthusiast

    Messages:
    2,073
    Joined:
    Dec 28, 2010
    Car:
    C43 AMG

    A faulty battery can cause all sorts of problems with the W211, but as said in this thread if your car is still on the original battery then it has done well to have lasted this long.
    I would personally change the small battery under the bonnet aswell as the main one in the boot :thumb:
     
    1 person likes this.
  11. OP
    OP
    maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    Many thanks everybody.

    Apologies for my ignorance here but the W211 has two batteries?!
     
  12. trapperjohn

    trapperjohn Hardcore MB Enthusiast

    Messages:
    7,314
    Joined:
    Nov 19, 2008
    Location:
    Lancashire
    Car:
    124 300D 24V Estate
    Yes two. PITA. (My trusty old 124 has just the 1)
    One runs the comfort features of your car. Central locking and such like.
    The other does the regular battery jobs such as starting.
     
    1 person likes this.
  13. OP
    OP
    maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    Oh great! Two new batteries.

    I'm trying to work out if I've had a repair/cost free month in my 15 months of MB ownership across two cars. I don't think there has been one.

    Love the car though.
     
  14. Danny DeVito

    Danny DeVito Hardcore MB Enthusiast

    Messages:
    880
    Joined:
    Nov 1, 2009
    Location:
    Ireland
    Car:
    V220 CDI
    Thats comical that is i can see Mae waving his arms after learning he has two batteries ! :rolleyes:

    And...sorry for your problem can't help but do check the battery dates it's important
     
    1 person likes this.
  15. terry obrien

    terry obrien New Member

    Messages:
    2
    Joined:
    Jun 8, 2011
    Location:
    ferrybridge, west yorshire
    Car:
    w211 eclass estate
    I'm in the same boat, alarm going off for no apparent reason, spoke to Merc mechanic who said its usually the built in siren battery that's had it and needs new siren as its all in one
     
  16. OP
    OP
    maestegman

    maestegman Hardcore MB Enthusiast

    Messages:
    101
    Joined:
    Feb 22, 2011
    Car:
    2003 E270 CDI Elegance
    Solved. Battery fine. Alarm now unplugged. Simples.
     
  17. Danny DeVito

    Danny DeVito Hardcore MB Enthusiast

    Messages:
    880
    Joined:
    Nov 1, 2009
    Location:
    Ireland
    Car:
    V220 CDI
    Did locking/unlocking not reset the alarm or did the remote not work ? And when it went off did you try unlock the car with the key ? And u said battery fine. did you mean one or both ? And remember the batt test is not always reliable so watch out for other problems which may be battery related. And last is good luck with your other problems is sounds like your list is as long as mine !! :0)
     
  18. Tinkerer

    Tinkerer Hardcore MB Enthusiast

    Messages:
    391
    Joined:
    May 5, 2011
    Location:
    Norfolk
    Car:
    W210 E220 CDi
    Excuse my ignorance, I know that the main battery is under the rear seat but I have never seen another one under the bonnet. How big is it and can you be more specific about the location please??
     
  19. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,087
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, MK1 Caddy, S500, etc
    Its a different car. You have a 210 and he is taking about a 211 that has an extra battery under the bonnett
     
    1 person likes this.
  20. englishdas

    englishdas Hardcore MB Enthusiast

    Messages:
    335
    Joined:
    Sep 1, 2010
    Location:
    South Yorkshire
    Car:
    57 E200 Kompressor
    Excuse my ignorance but mine has 2 batteries and its a 210. Is it due to it being a 320?
     
Tags:

Share This Page