1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

CL500 W215 drivers door electrics

Discussion in 'Electronics' started by TonyWillis, Dec 29, 2016.

  1. TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    All the electrics have stopped working in the drivers door following a flat battery and recharge. Most likely would seem to be the loom where it passes into the door but it looks untouched and the sheath is perfect. Is there a door control module in the door that might have failed?
    Any help gratefully received!
    Also does anyone know of a good mercedes specialist in the New Malden area (near Kingston upon Thames) that they could recommend?
    Thanks
    Tony Willis
     
  2. C43AMG

    C43AMG Hardcore MB Enthusiast

    Messages:
    6,161
    Joined:
    Apr 15, 2005
    Location:
    Weybridge. U.K
    Car:
    500L ( W221 ), 2014 AMG CL 5.5 Biturbo ( W216 ), 2010 Brabus Smart ( Exclusive ) )
    TM Motors 24 Central Ave West Molesley 0208 941 4044 Expert's on the 215's. Anton or Tony
     
    1 person likes this.
  3. AndyRan

    AndyRan Hardcore MB Enthusiast

    Messages:
    147
    Joined:
    Jan 22, 2016
    Location:
    Kent
    Car:
    R129 SL 500
    Dont be fooled by it looking OK - the only way to tell is to cut it open

    if your competent with a soldering iron its not too hard too do either
     
    1 person likes this.
  4. renault12ts

    renault12ts Hardcore MB Enthusiast

    Messages:
    13,853
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    Unlikely to be the loom since everything was working one day then all not working the next,
     
    1 person likes this.
  5. design guru

    design guru Hardcore MB Enthusiast

    Messages:
    344
    Joined:
    Feb 28, 2004
    Location:
    Hampshire
    Car:
    2001 W220 Mercedes S320cdi
    Possibly the door control module, does the indicator in the wing mirror or electric seats work?
     
    1 person likes this.
  6. Auto-mobile

    Auto-mobile Hardcore MB Enthusiast

    Messages:
    1,579
    Joined:
    Oct 1, 2011
    Location:
    Birmingham
    Car:
    2x c43 Amg clio 172 turbo 314bhp
    Broken live or earth in door hinge.
     
    1 person likes this.
  7. Noelmc

    Noelmc Member

    Messages:
    33
    Joined:
    Feb 1, 2016
    Location:
    Peterborough
    Car:
    CL500
    The "double hinge" arrangement on these doors is a known wire weak spot, but as suggested it's odd that it appears just as the battery goes down
     
    1 person likes this.
  8. Auto-mobile

    Auto-mobile Hardcore MB Enthusiast

    Messages:
    1,579
    Joined:
    Oct 1, 2011
    Location:
    Birmingham
    Car:
    2x c43 Amg clio 172 turbo 314bhp
    Wiring can completely break at any point, maybe just a coincidence? It fails over time, try operating a window while opening and closing the door.
     
  9. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    Hi guys and thanks for your responses. Nothing in the door works at all. not the windows, mirrors, seats including the heating, even the rear window on the passenger side so I recon it must be the live or neutral feeds. What colour wires are they?
    Thanks
     
  10. AndyRan

    AndyRan Hardcore MB Enthusiast

    Messages:
    147
    Joined:
    Jan 22, 2016
    Location:
    Kent
    Car:
    R129 SL 500
    Here was mine.

    Should be quite obvious - All worked one day, the next time nothing!

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  11. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,087
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, MK1 Caddy, S500, etc
    I must have repaired tens of these now.

    Its not a diffiult job but fiddly. Use shrink wrap and extend the wires a little too.
     
  12. C43AMG

    C43AMG Hardcore MB Enthusiast

    Messages:
    6,161
    Joined:
    Apr 15, 2005
    Location:
    Weybridge. U.K
    Car:
    500L ( W221 ), 2014 AMG CL 5.5 Biturbo ( W216 ), 2010 Brabus Smart ( Exclusive ) )
    I can vouch for that :thumb:
     
  13. AndyRan

    AndyRan Hardcore MB Enthusiast

    Messages:
    147
    Joined:
    Jan 22, 2016
    Location:
    Kent
    Car:
    R129 SL 500
    In an ideal world I would have pulled it all back and removed the entire factory wiring between the car and the door and replaced it all with a more flexible silicon covered wire as well.
    Adding in an inch or so does make a big difference
     
  14. Uky

    Uky Active Member

    Messages:
    77
    Joined:
    Jun 23, 2006
    Car:
    C207
    Just be a bit careful since the AirBag cable runs through this rubber hose as well.

    Ignition swith "on" when attempting to do anything with the harness will result in a SRS alarm which has to be cleared using Xentry.

    (I had to repair my harness too, and was surprised to find that MB had used standard not-very-flexible-cables.)
     
  15. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    Thanks all, that was my problem too. However I now have another problem - that the key will not open / lock the doors. The light on the key lights when any button is pressed. If I open the door with the manual key and put the key in the ignition then all the doors work normally. Then take the key out and buttons still work - opening and closing the doors for about 30 seconds, then nothing again. The buttons on the dash work fine so nothing wrong with the vacuum system. I only have one key so can't tell if it's the key or the car. (have ordered a new key from Mercedes) Took the car to and indy Mercedes garage (T M Motors in West Moseley) with no joy, then to Mercedes World in Brooklands and they are not sure what the problem is - where do I go from here??!
    Help please!
     
  16. C43AMG

    C43AMG Hardcore MB Enthusiast

    Messages:
    6,161
    Joined:
    Apr 15, 2005
    Location:
    Weybridge. U.K
    Car:
    500L ( W221 ), 2014 AMG CL 5.5 Biturbo ( W216 ), 2010 Brabus Smart ( Exclusive ) )
    I'm surprised TM couldn't solve the problem, they are pretty knowledgeable on the 215. Did Tony and Anton get involved ? Lets hope its the key., I know how frustrating the CL can be. Give Olly at PCS a call 02392 570123 a Forum Trader., he has looked after my CL for last seven years and knows the 215 inside out. Good luck.
     
    1 person likes this.
  17. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    I will see what happens when I get the new key from Mercedes next week. In the meantime, I have checked all the fuses that people have mentioned although Brooklands Mercedes say that as all the systems seem to be working, it is unlikely to be a fuse. I will try disconnecting the car battery for a system reset and see if that has any effect. The only other thing is that the alarm does not sound when I open the car with the manual key which may be a factor in the feedback system - but I believe that would not allow the car to start at all - any ideas anyone?
    Thanks again
     

Share This Page