1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

e 320 cdi epc light and power issue,s

Discussion in 'Engine' started by big john, Jun 17, 2010.

  1. big john

    big john Banned

    Messages:
    146
    Joined:
    Nov 25, 2009
    Location:
    blackpool
    Car:
    e 320cdi amg spec
    just noiticed tonite car running lumpy negine serging a little bit, pull away and theres seems to be like a knock noise down on power then 4 times on the run with in 10 mins car cuts out EPC light comes on restart car drives then cuts out????????????:confused:
     
  2. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,087
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, MK1 Caddy, S500, etc
    Can you explain in english please. It is a bit difficult to understand what you are saying.
     
  3. Tony Russell

    Tony Russell Hardcore MB Enthusiast

    Messages:
    139
    Joined:
    Jul 21, 2009
    Location:
    Glasgow ish.
    Car:
    Vaneo. 1.7CDi. I know. Stop laughing ! I need an MPV and it had to be Mercedes. OK ?
    I am no expert, however ....
    Sounds similar to the problem I had the other week.
    Was a blown injector seal. ECU detects lack of pressure in the system and shuts down the engine.

    Can you smell anything, like hot diesel, and see fumes ?
     
  4. renault12ts

    renault12ts Hardcore MB Enthusiast

    Messages:
    13,952
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
  5. OP
    OP
    big john

    big john Banned

    Messages:
    146
    Joined:
    Nov 25, 2009
    Location:
    blackpool
    Car:
    e 320cdi amg spec
    had it in at gary warburtons in fleetwood star macheind it failed injector or failing shall i say so new one going in on sat morning car was missing soon as i said he knew wot it was a qhick plug in and all was revieled, not to impressed though as the injectors not that old but being told it's a comon problem on the 320 cdi woundefull ehh and after doing a search this morning i aint the only one with the problem either, well hope it cures it anyway
     
  6. NW_Merc

    NW_Merc Banned

    Messages:
    5,918
    Joined:
    Sep 3, 2005
    Location:
    Over here, sometimes over there
    Car:
    1994 Mercedes C180 classic
    How, has it been diagnosed properly?
     
  7. renault12ts

    renault12ts Hardcore MB Enthusiast

    Messages:
    13,952
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    I think failed seals are common enough. But I'd say failed injectors are not.
     
  8. Peter Guilam

    Peter Guilam New Member

    Messages:
    14
    Joined:
    Oct 9, 2011
    Location:
    Lincoln
    Car:
    Mercedes E320 CDI 2001
    I get this error message on my E320 CDi, it is due to a dirty/blocked fuel filter, easy fixed and expected since I'm running on 100% Biodiesel at 15pence a litre. Car has run well on Bio fuel for 2 years and costs about 9 pounds to fill it up!
     

Share This Page