1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

Engine will not rev past 3000 RPM

Discussion in 'Engine' started by sv650smotorbike, Oct 15, 2005.

  1. sv650smotorbike

    sv650smotorbike New Member

    Messages:
    8
    Joined:
    Sep 27, 2005
    Location:
    Yorkshire
    Car:
    E220CDI
    I have a year 2000 E220CDI and the engine will not rev higher than 3000 rpm.

    It starts ok and runs ok for a while then the problem appears, quite worrying when your trying to overtake or coming out of a junction and suddenly the car will not accelerate!!

    I have recently replaced the glow plugs in the car and the fault first appeared when the plugs were faulty (safe mode) I thought the problem would clear once the plugs had been changed but was wrong. Have tried resetting the electronics but appears to be something else.

    Can anyone help - Deiselman has already suggested the MAV, but I dont know what this is or how to find it??
     
  2. mark.t

    mark.t Banned

    Messages:
    1,114
    Joined:
    Nov 22, 2003
    Location:
    manchester
    Car:
    E300 td tomtom sat nav in car dvd
    will it rev past 3000 when you are at stand still ....either you have left your speed limiter on (or has got stuck ) and not released the set linmt or your car is in limp home mode ...what gears can you get ...a vist to the dealers may be required
     
  3. mark.t

    mark.t Banned

    Messages:
    1,114
    Joined:
    Nov 22, 2003
    Location:
    manchester
    Car:
    E300 td tomtom sat nav in car dvd
     
  4. OP
    OP
    sv650smotorbike

    sv650smotorbike New Member

    Messages:
    8
    Joined:
    Sep 27, 2005
    Location:
    Yorkshire
    Car:
    E220CDI
    It will not rev past 3000 when at standstill once it has gone into its sleepy mode, somtimes when the car starts everything is ok - revs to redline and goes like a good un!

    I have never used the speed limiter, I can get all gears when driving (Auto)
     
  5. OP
    OP
    sv650smotorbike

    sv650smotorbike New Member

    Messages:
    8
    Joined:
    Sep 27, 2005
    Location:
    Yorkshire
    Car:
    E220CDI
    Sorry Yes I did mean MAF

    SV650

    My Other Car's a Motorbike!
     
  6. huliojulio

    huliojulio New Member

    Messages:
    1
    Joined:
    Oct 15, 2005
    The vehicle is going into limp mode for some reason. The glow plugs only purpose is to help with emissions control, they have no real bearing on how your engine runs wether they're working or not. Your going to have to take it to a garage I'm afraid. The good news is that there will definately be a fault code to point you in the right direction, but to get the code, it's garage time. :eek:
     
  7. mobeyone

    mobeyone Hardcore MB Enthusiast

    Messages:
    1,432
    Joined:
    Apr 23, 2005
    Car:
    E280 S211
    I would agree - find an indie nearby who has (win)star and get it plugged into see why.

    Mine is going in next week for an idle issue i have at the moment so fingers crossed i will have an answer.

    More money to spend on my motor........
     
  8. OP
    OP
    sv650smotorbike

    sv650smotorbike New Member

    Messages:
    8
    Joined:
    Sep 27, 2005
    Location:
    Yorkshire
    Car:
    E220CDI
    Thanks to eveyone trying to help, Can anyone reccommend a good indie in East Yorkshire where I live or near Leeds where I work??
     
  9. turbominor

    turbominor Member

    Messages:
    57
    Joined:
    Jul 24, 2005
    Location:
    evesham
    Car:
    W202 C180 Auto
    i looked at a 313cdi sprinter on friday with same issue and the fuel presure readings well way to low when i checked with my kts box. Changed the fuel pressure regulator (one at back end of rail) and now going like a train..

    If you think it could be the Maf sensor, disconnect it and test drive.
     
  10. mobeyone

    mobeyone Hardcore MB Enthusiast

    Messages:
    1,432
    Joined:
    Apr 23, 2005
    Car:
    E280 S211
    How far from stockport are you?

    I am meeting up with Steve who owns SPR Autos next week and he is a top bloke - very knowledgable on MB.
     
  11. minyak

    minyak Hardcore MB Enthusiast

    Messages:
    152
    Joined:
    Mar 9, 2005
    Hiya,

    I had an identical problem to yours few months back ( on a C220 CDi), and it was down to a split turbo pipe..so not enuf air was entering the compression and hence the ECU detects and limits the rev to which u can go. Check this out!!!!
     
  12. GERRY GALLAGHER

    GERRY GALLAGHER Banned

    Messages:
    25
    Joined:
    Nov 24, 2004
    Hi Sv650 Try Melvyn Scott In Leeds ,info. On Thread For Specialists In W.yorks. Good Luck G.g.
     
  13. C220CDI

    C220CDI Member

    Messages:
    34
    Joined:
    Jan 11, 2004
    I too have exactly the same problem at the moment. Recently changed the MAF sensor. Car run fine, but then goes into sleepy mode, where revs wont go over 3000rpm. If you switch off the car for a while, and switch back on, then all seems to be ok, till next time...............

    Please let me know what the solution is when you find out. meanwhile, ill get the turbo pipe checked.

    Many Thanks.
     
  14. mobeyone

    mobeyone Hardcore MB Enthusiast

    Messages:
    1,432
    Joined:
    Apr 23, 2005
    Car:
    E280 S211
    a nieghbour also mentioned to me the lack of air maybe the cause of my sluggish performance from time to time..

    will find out and feedback on saturday!

    I still think you need to reset the ecu via star when you change the MAF.....
     
  15. AlexR

    AlexR Member

    Messages:
    37
    Joined:
    Sep 8, 2005
    Location:
    Surrey
    Car:
    E320 Sportline Cab
  16. C220CDI

    C220CDI Member

    Messages:
    34
    Joined:
    Jan 11, 2004
    My mechanic, who works at Mercedes Benz, had the car checked on the computer at work today. The only fault it show is:

    P1470 - The charge pressure control is faulty

    Hes not quite sure what the problem is, so will seek some advise tmrw. He thinks its the charge control sensor ????

    I feel a big bill in the horizon.......................oh dear....
     
  17. C220CDI

    C220CDI Member

    Messages:
    34
    Joined:
    Jan 11, 2004
    any ideas ??
     
  18. turbominor

    turbominor Member

    Messages:
    57
    Joined:
    Jul 24, 2005
    Location:
    evesham
    Car:
    W202 C180 Auto
    my money is on the injector rail presure regulator. did the diagnostic give you fuel and boost presure levels?
     
  19. C220CDI

    C220CDI Member

    Messages:
    34
    Joined:
    Jan 11, 2004
    checked the printout, nothing there suggesting fuel and boost presure levels............
     
  20. minyak

    minyak Hardcore MB Enthusiast

    Messages:
    152
    Joined:
    Mar 9, 2005
    what about the turbo pipes..:)
     

Share This Page