1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help centre command dead

Discussion in 'Electronics' started by fairly38, Jul 28, 2017.

  1. fairly38

    fairly38 New Member

    Messages:
    1
    Joined:
    Jul 28, 2017
    Car:
    cl500
    hello. i have a lot electric problems with my cl500. any buttons of the center console doesn't work. even the audio system and airconditor are dead.. my batterys went flat since then all centre controls dont work :confused::confused::confused::confused:
     
  2. zipdip

    zipdip Hardcore MB Enthusiast

    Messages:
    1,283
    Joined:
    Mar 5, 2015
    Location:
    Essex
    Car:
    s320
    I am no expert but did you jump start the car,this can blow a fuse, it will be a 7.5 one,maybe at the end of the dash,somebody with knowledge of your exact car will give a more exact answer ok and welcome
     
  3. markjay

    markjay Hardcore MB Enthusiast

    Messages:
    15,434
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 Retrofitted by www.comandonline.co.uk
    On my W203 the COMAND fuse was in the engine bay fusebox (driver's side) and not in dash fusebox. Not sure about other models though.
     
  4. renault12ts

    renault12ts Hardcore MB Enthusiast

    Messages:
    14,197
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    What year CL500?
     
    1 person likes this.

Share This Page