1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

HELP please with these flashing green and red lights

Discussion in 'Electronics' started by GILES, Feb 23, 2010.

  1. GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    Hi guys, am a newbie on here, so apologies if this might be a moot subject, but I am well and trully stuck nonetheless.
    I have a '97 C180 Classic, Auto and up till now not a single problem. Recently I lost my last set of keys and had new set made via the main dealers..in the meantime, I had the car towed back home. I had to be rear-lifted as it is auto and was in Park.
    Keys arrived, but have the dreaded red/green light scenario on the mirror. Starter turns but engine wont kick in. Fobs are working no probs to unlock,lock, alarm etc....have tried new batteries in fob, charging car battery, synchronising the key, and still nothing. Would love to disable/bypass the immob as the car is old anyhow....is there a way I can do this, or do I have to fork out once again to the dreaded Dealers??
    Thanks in advance and sorry for the narrative...just trying to fit in as much info as poss
     
  2. d w124

    d w124 Hardcore MB Enthusiast

    Messages:
    12,110
    Joined:
    Dec 30, 2008
    Location:
    london
    Car:
    w124 3.6AMG styling E320 S124 Lorinser styling
    Immobiliser PS Welcome to the forum
     
    Last edited: Feb 23, 2010
  3. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    thanks mate...any ideas what i can do to make it start, or is this a dealer-only remedy??
     
  4. d w124

    d w124 Hardcore MB Enthusiast

    Messages:
    12,110
    Joined:
    Dec 30, 2008
    Location:
    london
    Car:
    w124 3.6AMG styling E320 S124 Lorinser styling
    I`M NOT SURE MATE BUT SOMEONE WILL COME ALONG :thumb:
     
  5. chiefski26

    chiefski26 Banned

    Messages:
    402
    Joined:
    Jul 23, 2008
    Location:
    london
    Car:
    c63 c43
    hi some one i know had same problem i think he had to go to the stealer,not 100% sure though
     
  6. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    Thanks guys...am trying to avoid giving them any more of my hard earned...already donated £168 for a new key!!....not a speck of gold on the thing either!!
     
  7. bennesspipers

    bennesspipers Hardcore MB Enthusiast

    Messages:
    1,550
    Joined:
    Jun 3, 2009
    Location:
    boston,lincs
    Car:
    '95 W202 C220 Elegance saloon & 2001 C240 V6 Sport Estate
    You did have the ignition ON when you were synchronising the key ?
     
  8. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    Hi Bennes, thanks mate....I've tried with the egnition on, off and even in the first position, but still nothing. Any help will be extremely appreciated.
     
  9. Alps

    Alps Hardcore MB Enthusiast

    Messages:
    6,780
    Joined:
    Nov 29, 2002
    Location:
    London\Essex
    Car:
    E63 Weistec AMG, E55 2004 Silver(SOLD), C36 AMG 1997 (SOLD)
    is this not the diode in the mirror issue?

    replacement mirror is the easiest option, plenty cheap on fleabay!
     
  10. d w124

    d w124 Hardcore MB Enthusiast

    Messages:
    12,110
    Joined:
    Dec 30, 2008
    Location:
    london
    Car:
    w124 3.6AMG styling E320 S124 Lorinser styling
    Very Very cheap ;)
     
  11. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    Nice one, thanks.....will try that and keep you updated. Might be a bit of a daft question but would both lights work with a duff diode??
     
  12. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    thanks for the advice guys...quick update. I've replaced the internal mirror, and with all indexes crossed cranked the engine...alas, the same two lights are flashing and car wont start!!
     
  13. OP
    OP
    GILES

    GILES New Member

    Messages:
    8
    Joined:
    Feb 23, 2010
    Location:
    Burton on Trent, Staffs
    Car:
    1997 C180 Classic Auto
    Hey all, update!!
    Having spent several days on different forums, harassing Google etc, have been to the Stealers..nice bloke called Pete told me my immobiliser is not disengaging for whatever reason. The car is 13 years old now and am not bothered about having the immobiliser, so been looking at ways to bypass or disconnect the system. so far to no avail, but am calling an auto-electrician over to have a look. Fingers crossed, this wont be silly money. I will share the procedure if this does not break any forum rules as it seems a common problem with our aging beauties.....thanks all.
     
  14. bennesspipers

    bennesspipers Hardcore MB Enthusiast

    Messages:
    1,550
    Joined:
    Jun 3, 2009
    Location:
    boston,lincs
    Car:
    '95 W202 C220 Elegance saloon & 2001 C240 V6 Sport Estate
    I'll be interested to hear the outcome, cant see how that would break any rules,carry on !
     
  15. BigG

    BigG New Member

    Messages:
    4
    Joined:
    Sep 9, 2009
    Hi Giles - I've got same problem engine cranks but will not fire and red/green flashing lights on mirror. I suspect either CPS or Immobiliser. Did you get yours disabled? If so how?
     
  16. 1nevster

    1nevster Member

    Messages:
    43
    Joined:
    Feb 26, 2010
    Location:
    Liverpool
    Car:
    C280, N Reg, W202
    Done plenty of work on this myself have a look HERE

    Other threads of mine cover it also if you search.
     
  17. xdingo

    xdingo New Member

    Messages:
    12
    Joined:
    Oct 10, 2011
    Car:
    mercedes c180 elegance automatic
    Hi same problem I would like to bypass the immobiliser.
    can you let me know please....car would start because that also it would lock,unlock
     

Share This Page