1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest, Official Club stickers are now available, if you have not already ordered some go grab them now! To order click this Link ----> CLICK ME Go get them whilst stocks last! To dismiss this notice click the cross to the right of this message.

SAM unit problem

Discussion in 'Electronics' started by pareq, Mar 1, 2012.

  1. pareq

    pareq New Member

    Messages:
    11
    Joined:
    Apr 22, 2011
    Car:
    C200K Sport
    Dear Benzers,

    I'm seeking advices about SAM problem.

    For the past several months, my car (MB C200K 2007) started to show up some warning messages (e.g tail brake lamp, run flat tyre, ABS & ESP) on instrument cluster. When I check the problem e.g. tail light, they were ok. The warning message appeared intermittently probably once in couple of days.

    I took the car to Mercedes authorised dealer for inspection. They advised that the front SAM unit was damaged by water leak. They found water inside the unit and part of it has already corroded. They sucked out the water as much as they can but still could not fix the warning message problem. Then they advised to replace the unit with a new one to avoid any serious problem in future.

    Questions:

    1) Is this (SAM damage by wataer ingress) is a common problem with Mercedes car?
    2) Anyone know if the SAM unit can be repaired instead of replacing with a brand new unit?
    4) The car is in full working condition despite the intermittent warning messages. Should I really replace/repair the SAM unit?
    3) Mercedes offered 50% discount for brand new SAM unit and 20% off for the labour . Should I grab this offer or look for some other alternative?
    4) Any chance for the above mentioned damaged on SAM unit to survive for several more years?

    Hope to get some useful comment and opinion regarding this issue.

    Thanks guys !!!
     
  2. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    New sam unit merc vito2008 £180+vat less 50 percent sounds like a bargain.it maybe an upgraded unit may not be. Some sam units are a bit suspect used sams £60~£120 from breakers or ebay. Unit splits into fuses and relays on top pcb clips on the bottom.can be fixed by good auto electrician.new unit may need reprograming.
     
  3. OP
    OP
    pareq

    pareq New Member

    Messages:
    11
    Joined:
    Apr 22, 2011
    Car:
    C200K Sport
    Total price to pay for part with 50% discount and labour with 20% discount is £355. Full price should be over £600. It is for Mercedes C200K Sport 2007.
     
  4. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Might be the best option parek i found a used unit yesterday but theres a slight difference in the sam.fitting a new unit next week headbash.:(
     
  5. flobots

    flobots New Member

    Messages:
    8
    Joined:
    Feb 28, 2012
    Car:
    vito 111
    I spoke to mb dealer today about SAM unit. A bit of good news is that they don't apparently need to be coded when new one is fitted.
     
  6. OP
    OP
    pareq

    pareq New Member

    Messages:
    11
    Joined:
    Apr 22, 2011
    Car:
    C200K Sport

    Stevieraylamb, can I know the quoted price ( part + labour + VAT ) and which Merc model ?
     
    Last edited: Mar 3, 2012
  7. OP
    OP
    pareq

    pareq New Member

    Messages:
    11
    Joined:
    Apr 22, 2011
    Car:
    C200K Sport
    Flobots, do you thinks this applicable to my car (C200K Sport 2007) ?
     
  8. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    That should keep the bill down a bit flobots:) will have a bash at fitting new unit in next few days.
     
  9. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Pareq new sam £180+vat didn,t get a price for fitting.
     
  10. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Just purchased a new sam from merc manchester £186.66 kats & kittens including vat. How goods that 15per cent discount, off to the pub.bannana.;)
     
  11. flobots

    flobots New Member

    Messages:
    8
    Joined:
    Feb 28, 2012
    Car:
    vito 111
    Hi pareq

    Don't see why it would be different between model for coding the same unit.

    Steve I'd leave the pub until after you'd fitted the Sam. To either celebrate or drown your sorrows. Fingers crossed mate.
     
  12. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Right here we go disconected the earth strap, took ecu out of the way, undid 4 screws holding fuses & lighting sam unit undid screw holding sam inplace, pulled sam out, down & to the left, fitted new sam, put everthing back in reverse order.started vito no lights & cluster displaying handbrake problelm. Refited old sam back in everthing back as it was before all lights working except fog & main beam.booked vito in for reprograming on wednesday.:(.
     
  13. OP
    OP
    pareq

    pareq New Member

    Messages:
    11
    Joined:
    Apr 22, 2011
    Car:
    C200K Sport

    :doh: :doh: :doh: But good attempt Steve. Maybe just no luck for this time. By the way, you book for reprogramming at dealer or independent garage?
     
  14. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    it going to a good indiependent pareq they have all the diagnostics taking the earth strap off turn the drl,s off so it was not all bad.:)
     
    1 person likes this.
  15. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Here we go again guys took vito had new sam fitted.did not need coding you were dead right flobots. Even with new sam fitted still no mainbeam or fogs looking now at the loom
    or maybe relay.
     
    1 person likes this.
  16. stevieraylamb

    stevieraylamb Member

    Messages:
    45
    Joined:
    Jan 24, 2012
    Turns out the female connecter the sam sits into had split causing a short between the fog and main beam problem solved
     
  17. sammo1985

    sammo1985 Member

    Messages:
    42
    Joined:
    Mar 15, 2013
    I'm just going through this problem, connected upto star and said that short in rear lights, SRS malfunction and intermittent problems with PT sensors. Chap I use thinks it could all be related but wants to look at wiring before changing SAM unit. Strange problem as car doesn't seem to really have any problems.

    I have an E320 W211, any known faults with these?
     
Tags:

Share This Page