Search results

  1. Velo96

    C200 kompressor supercharger - M271

    Hi, I would try to connect odb2 reader and see if any faults come up i have purchased a c180K 2005 m271 and I've had timing chain problems so I got that fixed, next I looked into getting more power for it but m271 engine is pretty limited to what you can get :( however I have fitted a boost...
  2. Velo96

    W203 C180K (P0340) code

    I did but he obviously a cowboy so won't tex me
  3. Velo96

    W203 C180K (P0340) code

    Top dead center and intake cam looks way off, is there a way to rotate the camshaft with cam adjuster without taking the chain of?
  4. Velo96

    W203 C180K (P0340) code

    quick update i have changed engine oil, checked spark plugs/coils look ok. checked camshaft postion sensors with multimeter and i couldnt get any reading from the both sensors unless i was doing something wrong.
  5. Velo96

    W203 C180K (P0340) code

    hi i have recently purchased my first petrol car in 10 years 2005 w203 c180 kompressor i drove it home (70m) and near my house the car lost all power over 1200rpm so i checked stored codes with odb reader and it showed 2x P0340 (camshaft position sensor A circuit Bank 1 or sinsgle sensor) and...
  6. Velo96

    W210 OM606 overheating

    I thought about head gasket but water is clean no mixing, smoke etc soo I besides to take the water pump out and behold theres my problem
  7. Velo96

    W210 OM606 overheating

    hi my w210 developed another problem and i dont want to give it up yet, engine started overheating after i accelerated from a junction when the car is idling it wont overheat but when im driving under 3k rpm it will eventually start overheating or when the engine is heated to normal temp if i...
  8. Velo96

    w210 e300td heater always blowing cold air

    I've just took duo valve apart again give it a good clean now there is hot air but only when I'm driving or reving on idle it blow cold air, I will order a new duo valve, in mean time is there a way to bleed the system?
  9. Velo96

    w210 e300td heater always blowing cold air

    I am unsure but the duo valve does get hot and and the 2 wee valves moves up and down freely
  10. Velo96

    W210 E300TD fuel problem

    fixed turned out it wasnt a problem with the fuel but the intercooler hard pipe under the intake manifold was missing a screw for support bracket and when i put the manifold back on the egr valve and cooler hard pipe didnt line up and created a gap inbetween so hence why there was no power.
  11. Velo96

    w210 e300td heater always blowing cold air

    hi i have an issue with the heater system always blowing cold air i have replaced thermostat and cleaned the duo valve but issue still here the motor seems to work as blowing cold air, i noticed if i turn the dial from hot to cold the sound would get louder but still cold air. anyone have a...
  12. Velo96

    W210 E300TD fuel problem

    Hi all, I'm having some problem with my e300td after fixing a fuel leak from the delivery valves 1 and 2, after starting the car there was loads of white smoke, went for test drive and engine sounded louder, on idle would rev up to red rpm but driving its really splutery won't go over 2k rpm...
  13. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    Problem solved! The electrician said the alternator was overcharging and blew a module in the abs ecu so needed both of them, but before told me the alternator was fine... anyway 340£ for the fix. Cheers guys
  14. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    I have the car in electritions since Tuesday and they done many tests including alturnator so they told me there computer showing up a fault with abs, checked abs pump etc all good so they said there 80% sure abs ecu is faulty
  15. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    https://vimeo.com/567917231
  16. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    Little update I changed the brake light switch behind the pedal and problem still here I have noticed when rev over 3k rpm the interior light goes off and all lights get dimmer/ brighter like some voltage fault i have replaced the battery still same need help, still haven't received my ob2 adaptor
  17. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    I have ordered a obd2 adaptor for 38 pin hopefully receive it this week and get it checked as need to fix this issue asap I dont want to damage something even more as I'm no pro with these engines
  18. Velo96

    ABS, BAS, ASR FAULT W210 300TD

    ive been having some gearbox issues lately when i put throtlle in over 4k rpm abs,bas,asr lights come on when driving and it wont shift up unless i slow way down then lights go off and drives normally same as being parked if reved over 4k rpm lights come on, anyone know what this could be as i...
  19. Velo96

    W210 E300TD wont change up gears

    Quick update i checked how much oil I removed was around 4L, so I empty all oil that I put in and only around 4L came out after me putting in 6 so must need to drain torque converter too, I just added 2L and now the dipstick is at max level when hot however the original fault it still here
  20. Velo96

    W210 E300TD wont change up gears

    That's the way it was before I changed oil for 2 years and no i haven't
Back
Top Bottom