Search results

  1. T

    CV Gaitor Melted!!

    CV gaitor fixed Finally i got round to replacing the cv gaitors on my ML270, pretty easy in the end and both replaced for £15 instead of £300 for the parts only from MB.. cheers Trevor
  2. T

    CV Gaitor Melted!!

    Yes Franey had actually managed to get hold of one at a very good price too...i didn't go for it as was having trouble with the hub nuts and thought i would end up having to put to a garage. Anyone know if the outer cv joint is held with an internal cir-clip and so can be just knocked off...
  3. T

    CV Gaitor Melted!!

    Thanks all, Managed to get a boot from my local motor factors when i was there getting a 36mm impact socket for the hub nut. It was very cheap aftermarket item but will give it a go and see how it lasts.....Could replace it 21 times and still be quids in from the Mercedes price!! I am now...
  4. T

    Diagnostis Trouble Codes - HELP!!

    Hi All, Yes apologies for not mentioning car model...:doh:...my bad....will update profile and see if i can add it there.... Ye battery id definitely over three years old so will change and see what happens. Thanks for all your help. cheers Trevor
  5. T

    CV Gaitor Melted!!

    ah ok i cant get the vin just now but will post later. Do you have a site i can buy this aftermarket? thanks
  6. T

    Diagnostis Trouble Codes - HELP!!

    Hi Danny, yes all 10 faults still there. It is a 2002 ML270 (w163). Would be good to know where module is as there seem to be a few. thanks Trevor
  7. T

    CV Gaitor Melted!!

    Yeah thanks for that just seen them online. I need to get the drive shaft out of the way to drill out the bolt i sheared so might as well fit a non split one. I see that you can get universal stretch ones for around a tenner....will probably go down this route...still not sure how much i need to...
  8. T

    CV Gaitor Melted!!

    £150!!! god really.:eek:....oh dear that was an expensive mistake.....I was trying to save the £250 quoted to chage the front anti roll bar bushes and rear cross member brakeline...guess thats blown it now...
  9. T

    Diagnostis Trouble Codes - HELP!!

    Thanks guys. I have not tried a different battery yet but if this can give these problems then it may just be that as the diagnostic machine i have did show a lowish voltage during cranking...around 9.5v I have a Mercedes enhanced diagnostic kit so trying to avoid paying for star as that was...
  10. T

    CV Gaitor Melted!!

    Evening All, I am needing to change the outer CV gaitor on my ML270 W163 as i got a bit over enthusiastic with the blow torch when trying to get a snapped front anti roll bar bolt out. :doh::( My question is can i just remove hub nut (easier said than done) and then the top and bottom...
  11. T

    Diagnostis Trouble Codes - HELP!!

    Hi thanks for replies....have cleared codes but still getting these ones up. Occasionally the yellow triangle on the dash flashes when going slowly and a grinding can be felt through the brake pedal. Not sure whats going on there as if its abs kicking in i thought the abs light would have come...
  12. T

    Diagnostis Trouble Codes - HELP!!

    Fair enough...thanks for replying though....:D
  13. T

    Diagnostis Trouble Codes - HELP!!

    :dk: 77 views and no replies!! Have i done something wrong? :(:(
  14. T

    Diagnostis Trouble Codes - HELP!!

    Update All, Just to update, I changed the rear left ABS sensor as a couple of codes pointed to that. Also i was getting no reading from the front right sensor at all and this turned out to be a loose connector. Once i cleared all the codes and reset the steering wheel and went for a drive all...
  15. T

    Diagnostis Trouble Codes - HELP!!

    Hello All, Have been having trouble with gearbox going into limp home mode straight away and BAS, ESP, ABS and EPC lights on. I bought an Autoenginuity scanner with the enhanced Merceds package cleared all codes then read after short drive and got the following codes and wondered if anyone...
  16. T

    handbrake light

    Hello All, Anyone experienced the handbrake light coming on with a buzzer and gearbox stuck in gear? cheers Trevor
  17. T

    Pilot Bush

    Hi All, I am changing the pilot bush on my ML270 due to oil in the wiring loom and gearbox module issue. I have had the bottom half of the dash out to clean all the oil from the loom and inside the module and am now working on the underside of the car. Problem is i cant seem to get the new...
  18. T

    K6 Relay Testing

    Hi , yes i have checked the wheel sensors and they all read the same around 1500 ohms. I did notice that the rear nearside one looked fairly new and from an aftermarket supplier....i have only had the car since last August.... I see that Gendan do a Mercedes specific advanced reader for...
  19. T

    K6 Relay Testing

    Morning All, I am having trouble with my ML270 2002. The three braking system lights are on. When i start the car and begin to drive the yellow triangle flashes as if looking for or testing something and then a fourth light comes on...epc...i think and the triangle stops flashing..... I have...
  20. T

    ETS light and brake pulse

    Hi thanks for reply....i tested all the wheelsenors and they all read 1.07kohms. I then tried to take them out to clean but one snapped off as i was doing it so will have to get a replacement....got another one out no problem but the other two are stuck and don't wantto break thm as well
Top Bottom