1984 280SL smokes

Discussion in 'Engine' started by HILTON WOLFF, Dec 21, 2014.

  1. HILTON WOLFF

    HILTON WOLFF Member

    Messages:
    51
    Joined:
    Oct 22, 2009
    Location:
    SOUTH AFRICA
    Car:
    merc 220ce
    I have a 1984 280SL ,with 185000 KMS on the clock.When driving at at a speed above 90KMS PER HOUR and I
    decellerate and then accellerate a puff of smoke comes out of the exhaust.
    I was told it is the valve stem seals,had the cylinder head redone ,new valve stem seals fitted ,all genuine parts and yet the problem still exits.
    While the cylinder head was off,I was told that everything looked good.
    Please let me know if anybody has had the same problem ,and how can it be fixed without overhauling the engine.
    Thanks,
     
  2. pembssurf

    pembssurf Hardcore MB Enthusiast

    Messages:
    677
    Joined:
    Oct 23, 2014
    Car:
    toyota
    This doesn't help but sounds like classic valve stem seals. As long as it's not using touch oil I would it worry. Is the smoke blueish grey in colour or blacker darker?
     
  3. OP
    OP
    HILTON WOLFF

    HILTON WOLFF Member

    Messages:
    51
    Joined:
    Oct 22, 2009
    Location:
    SOUTH AFRICA
    Car:
    merc 220ce
    Smoke is grey,
    Thanks
     
  4. OP
    OP
    HILTON WOLFF

    HILTON WOLFF Member

    Messages:
    51
    Joined:
    Oct 22, 2009
    Location:
    SOUTH AFRICA
    Car:
    merc 220ce
    Oil used is +- 1litre per 1000 KMS
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.