2001 W210 Heated Seats

Discussion in 'Electronics' started by Voyager, Feb 1, 2015.

  1. Voyager

    Voyager Hardcore MB Enthusiast

    Messages:
    123
    Joined:
    Oct 31, 2008
    hello - have a question

    The two front heated seats on my car have stopped working, however the switches that activate them still illuminate.

    Is there one fuse for both seats or could it be something else ?

    It'd be unlikely the connectors for both seats would become dislodged at the same time......

    Thanks:wallbash:
     
  2. bob6600

    bob6600 MB Club Veteran

    Messages:
    5,449
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    Check fuse 12 under the bonnet and fuses 17 and 18 under the rear seat
     
  3. OP
    OP
    Voyager

    Voyager Hardcore MB Enthusiast

    Messages:
    123
    Joined:
    Oct 31, 2008
    thanks for your reply bob6600

    I've done as you've suggested; fuse 12 and 18 is ok but fuse 17 was not installed. Funny, because i haven't been in the rear fuse area for months and am sure the heated seats have worked since then.

    To add another element to this - the passenger seat seat omit a little bit of heat to one side and the driver is still dead. Strange as they used to be piping hot - can imagine all the heating element going at once as they're wired in parallel and should continue working when an adjacent one fails ??

    mm?:dk:
     
  4. OP
    OP
    Voyager

    Voyager Hardcore MB Enthusiast

    Messages:
    123
    Joined:
    Oct 31, 2008
    thanks -pls see below
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.