2004 C180K Coupe Coolant Loss

BaldGuy

MB Enthusiast
Joined
Jun 1, 2002
Messages
4,310
Location
Berkshire & London
Car
Porsche + BMW + Mercedes
My Coupe daily snail uses water, its done 56k miles and freshly serviced 2 months ago.... no visible leaks and no oil in water.

I can regularly sit in London traffic, recently on Friday for 2 hours slow traffic... and i can smell coolant... the gauge never rises and i have only had the "add coolant" message on the dash once as i'm over cautious and always check the water.

I've read on here and the web that the expansion cap could be the culprit, so I have one coming next week... anything else to look at?
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,909
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Have the cooling system pressure tested if it continues to lose coolant.
 

clk320x

Hardcore MB Enthusiast
SUPPORTER
Joined
Sep 27, 2016
Messages
11,047
Location
UK
Car
W212 & W211
My Coupe daily snail uses water, its done 56k miles and freshly serviced 2 months ago.... no visible leaks and no oil in water.

I can regularly sit in London traffic, recently on Friday for 2 hours slow traffic... and i can smell coolant... the gauge never rises and i have only had the "add coolant" message on the dash once as i'm over cautious and always check the water.

I've read on here and the web that the expansion cap could be the culprit, so I have one coming next week... anything else to look at?

My expansion tank had blistered. Used to need top up every so often. Terry changed the expansion tank and all was good :thumb:
 

Users who are viewing this thread

Top Bottom