2018 C220d Cabriolet keeps sticking in 1st gear when stuck in traffic

Page may contain affiliate links. Please see terms for details.

Stirlin

New Member
Joined
May 22, 2023
Messages
21
Location
Glasgow Scotland
Car
2018 C220d Cabriolet - Premium Plus Night Edition
Hi all

Newbie here, I have a c220d cabriolet 2018 premium plus night edition.

The car drives perfectly with no warning lights on the dash, and its fine for miles and miles and ehen I get stuck in traffic it keeps hlheeting jammed in 1st gear.

It will manually change up from steering wheel paddles at 2000 rpm in every gear, it will not automatically change up.

Normally the car is fine, motorway speeds 70 ish with no problems, it changes up the gears automatically normally with no fallts.

I just had gearbox serviced as I thought that may be causing it , but the fault is still there , when i get stuck in traffic or at lights or behind some slow poke on their phone.

Turn engine off and back on again and its perfectly fine until I get stuck in traffic again.

Its the 9 speed auto trans, the car is the 170hp version with 400nm torque, 60k miles, doesnt get driven fast.

Any help would be very much appreciated, ive reset fault codes, ive reset transmission from key and pedal but it atill keeps happening sporadically, and its very annoying after spending 20k on whats supposed to be a luxury car!
 
How were the faults reset?
Was Star used to read the codes?

The "key and pedal" reset really does nothing

When you have this fault is the gear selector in the instrument cluster showing "M" or another setting?
 
How were the faults reset?
Was Star used to read the codes?

The "key and pedal" reset really does nothing

When you have this fault is the gear selector in the instrument cluster showing "M" or another setting?
Hi, thanks for responding.

Yeah I reset the faults myself, using the peddle method and also disconnecting battery.

Its sporadically doing it, so it must he an electrical fault, as a mechanical fault usualy does the same thing every time.

I have no lights on dash at all, not even engine management light.

I think it says D1 , but to be honest I've been too flustered changing gears up when it happens, as its always when i get stuck at lights or behind cars.

Windscreen was new last month bit im sure it happened before that was changed .

I can stop at the lights 100 times without fault and then that 1 time it happens again... im selling the car so would like it perfect for new owner with no problems.
 
It could be many things so a proper diagnosis by someone who has the MB Star system is needed.
 
It could be many things so a proper diagnosis by someone who has the MB Star system is needed.
Brilliant, thanks for the information , I thought because there are no warning lights on dash, there would be no error to clear except the memory, I will give my guy a phone tonight and ask if he has star to diagnose, dont fancy dealer prices at all!! ... I really appreciate the help, thank you 😊
 
Brilliant, thanks for the information , I thought because there are no warning lights on dash, there would be no error to clear except the memory, I will give my guy a phone tonight and ask if he has star to diagnose, dont fancy dealer prices at all!! ... I really appreciate the help, thank you 😊
There will be MB specialists near to you that have the required diagnostic equipment and they will be far better on cost than a dealer.

Hopefully someone can recommend an Independent specialist close to you.

The transmissions and associated electronics can be complex in their interactions so expert diagnosis is the best and most cost effective way forward.

Do you have any warranty on the vehicle?
 
My MB also was getting stuck in 1st gear and would not shift, either manually or automatically. No fault codes at first but then it failed when under STAR diagnosis and was found to be a rear (OS) wheel speed sensor. Overall stuck in gear 4 times. MC reluctant to change sensor but I (politely) insisted. No re-occurance of fault since senor change.
This may not be your fault, but it is something to eliminate.
 
My MB also was getting stuck in 1st gear and would not shift, either manually or automatically. No fault codes at first but then it failed when under STAR diagnosis and was found to be a rear (OS) wheel speed sensor. Overall stuck in gear 4 times. MC reluctant to change sensor but I (politely) insisted. No re-occurance of fault since senor change.
This may not be your fault, but it is something to eliminate.
Thanks for the info, very much appreciated, I'm going to my usual garage today to ask if tbey know anyone who has star, if not, I have a Mercedes specialist not too far away from me.

I'll post an update when I have more information, thanks again 😊
 
There will be MB specialists near to you that have the required diagnostic equipment and they will be far better on cost than a dealer.

Hopefully someone can recommend an Independent specialist close to you.

The transmissions and associated electronics can be complex in their interactions so expert diagnosis is the best and most cost effective way forward.

Do you have any warranty on the vehicle?
Thanks for the info, I bought it privately so no warranty unfortunately.

Im going to my usual garage today to ask if they know anyone with star, if not I have a Mercedes specialist not too far away.

I'll post an update when i know more, I really appreciate all of your help, thanks 😊
 
Hey 👋

I'm still trying to organise a specialist with Star.

But... Ive just realised the cat isnt stuck in gear at all, its just not changing automatically until 2500rpm (ish)

Also Start/Stop goes green when the fault occurs, it starts and stops but the problem is still there until I switch ignition off and thrn back on.

Just thought I'd post this update infp for everyone incase they have the same problems! I really appreciate everyone's help. ✌️
 
Hey 👋

I'm still trying to organise a specialist with Star.

But... Ive just realised the cat isnt stuck in gear at all, its just not changing automatically until 2500rpm (ish)

Also Start/Stop goes green when the fault occurs, it starts and stops but the problem is still there until I switch ignition off and thrn back on.

Just thought I'd post this update infp for everyone incase they have the same problems! I really appreciate everyone's help. ✌️
You’re not in manual mode by any chance? It will hold on to a gear until the revs get too high then override your selection. My wife managed to discover this …. Restarting reverts to automatic mode.
 
You’re not in manual mode by any chance? It will hold on to a gear until the revs get too high then override your selection. My wife managed to discover this …. Restarting reverts to automatic mode.
Hiya, thanks for the info, when it happens, it will change gears with paddles at 2000rpm or higher,
And it will Auto shift at approx 2500rpm .

Its very strange, I just spoke to my computer guy and he said it could be due to temperature if it only happens when stopped at lights.

He's really busy, but he says he can come out middle of next week, so im at his mercy until then.

Will post any updates and information as soon as I know .

Thank you to everyone for taking the time to respond to me. It's very much appreciated! ❤️
 
Most decent DIY scan tools can read real time pulses from the rear wheels . Was the TCU plug changed/checked for internal leak during the service ? and the loom inspected for ATF ingress ? Very cheap and easy DIY job.
 
Most decent DIY scan tools can read real time pulses from the rear wheels . Was the TCU plug changed/checked for internal leak during the service ? and the loom inspected for ATF ingress ? Very cheap and easy DIY job.
It's a 2018 9speed automatic.

I think the leaking connector and wicking of fluid into the TCU was an issue with the earlier 5 speed transmissions 🤔
 
Hiya, thanks for the info, when it happens, it will change gears with paddles at 2000rpm or higher,
And it will Auto shift at approx 2500rpm .

Its very strange, I just spoke to my computer guy and he said it could be due to temperature if it only happens when stopped at lights.

He's really busy, but he says he can come out middle of next week, so im at his mercy until then.

Will post any updates and information as soon as I know .

Thank you to everyone for taking the time to respond to me. It's very much appreciated! ❤️
If you touch the paddles it goes into manual mode, hence my question.
 
If you touch the paddles it goes into manual mode, hence my question.
Ah yes I see.....when it happens the dash doesn't change to M ... it stays on D even when paddle shifting up at 2000rpm, it womt change before those revs, paddle pressed multiple times and no change until 2000rpm.
 
I have the 9 speed box. With the car in comfort mode, the car doesn't go into first in traffic only second. In sport mode they go into first when you stop, which may explain t changing up at high revs.
 
I have the 9 speed box. With the car in comfort mode, the car doesn't go into first in traffic only second. In sport mode they go into first when you stop, which may explain t changing up at high revs.
Thanks for the info Sally.

I did think it may be changing between driver modes, and I tried changing the settings when it happens, but it makes no difference.

I noticed it stays in 2nd gear, until your actually stopped, then it pops back into 1st,. That's when i have the problem, but it happens sporadically , 1 time out of 100.

The computer guy mentioned it could be down to heat, as it only happens when engine is warm, and im stopped with engine running , so I will check to make sure my cooling fan is worrking, temperature gauge is showing normal in car,.

Hopefully we get some answers next week, I appreciate all of your help, thanks 😊
 
When you say gearbox service do you mean that the oil has just been changed? If so was the correct spec of oil used and noting that the procedure is quite specific was the oil level checked properly afterwards (inc minotoring the temp using XEntry etc)? I had many cheaper quotes to change the gearbox oil on my car but gave it to Mercedes as its not a straighforward drain, replace filter and top up job. Of course if this was done at the MB main stealer or specialist then this could be excluded, but could be worth investigating/ruling out how the garage did the job if it wasn't this type of garage doing the work?
 
What mode are you driving in, Eco, Comfort, Sport or sport +?
 

Users who are viewing this thread

Back
Top Bottom