2023 GLB Limp home mode (no codes recorded)

Page may contain affiliate links. Please see terms for details.

Frankp2112

New Member
Joined
Dec 4, 2023
Messages
1
Location
UK
Car
GLB
Hi,

I have 2023 GLB 200 petrol.

Yesteday I was accelerating hard away from a roundabout and the car dropped into limp mode. The MEL light came on and it was amber.

I pulled over turned the car off had a look round the restarted the car and the light went out and the car behaved ok. Few miles later while accelerating the same thing happened.
I called the Mercedes roadside support they connected the diagnostics and there were no stored codes.

Anyone had a similar experience or could suggest what happened ?

Thanks

Frank
 
Had the engine light illuminate on my 22 GLB200 3 times, last time stayed on for 2 days including a 98 mile trip, never gone into limp mode tho. When serviced I asked the dealership to check for fault codes, they said there weren't any as the ECU is self repairing and deletes fault codes when it does 🤔🙈
 
Hi,

I have 2023 GLB 200 petrol.

Yesteday I was accelerating hard away from a roundabout and the car dropped into limp mode. The MEL light came on and it was amber.

I pulled over turned the car off had a look round the restarted the car and the light went out and the car behaved ok. Few miles later while accelerating the same thing happened.
I called the Mercedes roadside support they connected the diagnostics and there were no stored codes.

Anyone had a similar experience or could suggest what happened ?

Thanks

Frank
I have had a similar fault caused by oil surge in the crankcase. 2007 E320S CDi. The fault also occurs when accelerating hard up a steep hill. However, it only occurs when the oil level falls below halfway on the dipstick. (my oil level drops due to leaking oil cooler seals).

Its unlikely your problem is caused by oil surge on such a new car as yours but its worth checking the oil level. In my case limp mode activated without the MEL coming on. The reasonI suspect it is oil surge is because limp mode only comes on when the oil level is below max and I accelerate hard uphill. That level of oil produces no warnings or alerts with normal driving.
 

Users who are viewing this thread

Back
Top Bottom