320 CLK won't start

Discussion in 'Engine' started by mr.tench, Jul 10, 2017.

  1. mr.tench

    mr.tench New Member

    Messages:
    1
    Joined:
    Jul 10, 2017
    Car:
    320 CLK
    Hi, My CLK 320 has just let me down. The engine cranks but won't start. it runs lumpy for about 10 - 15 secs then stops. Fortunately this happened on my driveway. It ran fine this morning. Is this a symptom of an air flow sensor failure?
    Thanks.
     
  2. rorf

    rorf Hardcore MB Enthusiast

    Messages:
    424
    Joined:
    Jul 23, 2011
    Location:
    Cape Town, South Africa
    Car:
    2000 SL320 v6, 2001 CLK320
    Usually the Crankshaft Position Sensor which needs replacement - 10 minute job. A blocked fuel filter can also cause this problem
     
  3. pcthrillrider

    pcthrillrider Hardcore MB Enthusiast

    Messages:
    119
    Joined:
    Feb 28, 2015
    Location:
    chelmsford essex
    Car:
    2012 c220cdi blue effiency se executive
    do the job correctly, read the dtc codes delete them,try again if same code comes back thats your problem
     
  4. rorf

    rorf Hardcore MB Enthusiast

    Messages:
    424
    Joined:
    Jul 23, 2011
    Location:
    Cape Town, South Africa
    Car:
    2000 SL320 v6, 2001 CLK320
    Most times a faulty crank shaft position sensor does not show up codes:cool:
     
  5. rorf

    rorf Hardcore MB Enthusiast

    Messages:
    424
    Joined:
    Jul 23, 2011
    Location:
    Cape Town, South Africa
    Car:
    2000 SL320 v6, 2001 CLK320
    Disconnect the MAF to see if there is any change when running, if not then MAF is faulty
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.