advise needed - battery light coming on for W202 1997 C200

classik

New Member
Joined
Feb 9, 2017
Messages
4
Car
mercedes c200
Hi Mercedes Brothers & Sisters!

I have a W202 Mercedes, 1997 C200 Classic / Elegance.
It's covered 200,000 miles but overall is fairly trusty.

Recently the car battery light has started coming on - intermittently.
Definitely more likely to happen upon "cold" - first usage of the day.
I have noticed no changes with the performance of the car.
The battery was replaced many years ago and so was the alternator.
Upon on basic visual inspection the drive belt and tension look OK.

To be sure, I took the car to my local auto repair centre.
They tested both the battery and alternator - suspecting it's most likely the alternator.
Surprisingly the voltmeter test showed no issues with both.
They then recommended posting on a forum to see if anyone with experience had advise upon the matter,
as it could be something minor.

If anyone can help it would be much appreciated.
Thanks,

Joe
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,909
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Welcome Joe

How did they test the battery? A proper test involves putting the battery under load. Do you know what the the battery voltage was with the engine off and at fast idle?

You say you replaced the battery "many years ago" how long ago was it?

Some alternators have an excitation circuit, this usually needs a certain engine speed for a few seconds from cold to exstinquish the warning light, not sure if your vehicle has this.

With a car of this age it is worth checking the state of the battery earth strap and starter earth as well.
 
Last edited:
OP
OP
C

classik

New Member
Joined
Feb 9, 2017
Messages
4
Car
mercedes c200
Hi and thanks for the quick reply!

Bear in mind that I'm a layman.
We turned over the car and he tested the battery with a voltmeter. We then put the heater on full, switched the lights and radio on also.
Later on we did the same and reved the engine too.
This was done for battery and alternator tests.

Readings were "fine".

Hard to say with the battery - could easily be 5 years plus.

"Some alternators have an excitation circuit, this usually needs a certain engine speed for a few seconds from cold to exstinquish the warning light, not sure if your vehicle has this."
This could well be the case - but then why has only started happening now and not before?

Will check the earth straps as you advise.

Many thanks,
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,909
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Hi and thanks for the quick reply!

Bear in mind that I'm a layman.
We turned over the car and he tested the battery with a voltmeter. We then put the heater on full, switched the lights and radio on also.
Later on we did the same and reved the engine too.
This was done for battery and alternator tests.

Readings were "fine".

Hard to say with the battery - could easily be 5 years plus.

"Some alternators have an excitation circuit, this usually needs a certain engine speed for a few seconds from cold to exstinquish the warning light, not sure if your vehicle has this."
This could well be the case - but then why has only started happening now and not before?

Will check the earth straps as you advise.

Many thanks,

Battery readings should be around 12.6V fully charged with no load and around 14.2 - 14.4V with the engine at idle.

It is important to know these figures as too high an output from the alternator can damage the battery, as to why things have just started happening, well that is the nature of things, faults develop with age.
 
OP
OP
C

classik

New Member
Joined
Feb 9, 2017
Messages
4
Car
mercedes c200
I'm pretty certain the figures were around what you are stating - though I would have to go back to confirm 100%.

So if this is the case and the straps are sound, would your suspicions be with a faulty alternator?
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,909
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
I'm pretty certain the figures were around what you are stating - though I would have to go back to confirm 100%.

So if this is the case and the straps are sound, would your suspicions be with a faulty alternator?

It is possible yes, I would try an Auto-Electrician who can check out things in more detail such as the rectifier pack on the alternator and should be able to test the battery under a load .
 
OP
OP
C

classik

New Member
Joined
Feb 9, 2017
Messages
4
Car
mercedes c200
Brilliant! Really appreciate your time and effort. Best wishes, Joe.
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,909
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Brilliant! Really appreciate your time and effort. Best wishes, Joe.

You are most welcome Joe. It is what the forum is (supposedly) for, helping each other!

Let us know what the problem was once you have a solution , it adds to the overall knowledge base.:thumb:

David
 

Users who are viewing this thread

Top Bottom