Air-con not coming through centre vents

Discussion in 'General Discussion' started by mun35, Nov 12, 2016.

  1. mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    Hi

    On my dad's W202 C180, the air-con works but no air comes from the centre vents. Does anyone know why this might be the case? Could a fuse be blown or something simple?

    Any help appreciated.
     
  2. Peter DLM

    Peter DLM Hardcore MB Enthusiast

    Messages:
    2,274
    Joined:
    Aug 24, 2007
    Location:
    Milton Keynes
    Car:
    17 reg E220d AMG Estate, 17 reg Smart Prime, Caterham Levante and E92 M3.
    I believe the centre vents are fresh air only.
     
  3. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    There used to be air-con air coming from the centre vents. Now the side vents feel much stronger than before and nothing comes through the centre vents.
     
  4. Peter DLM

    Peter DLM Hardcore MB Enthusiast

    Messages:
    2,274
    Joined:
    Aug 24, 2007
    Location:
    Milton Keynes
    Car:
    17 reg E220d AMG Estate, 17 reg Smart Prime, Caterham Levante and E92 M3.
    In that case, please disregard.
     
  5. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,469
    Joined:
    Jul 28, 2004
    Car:
    C180,A. September '97 48k
    Is the centre vent thumb wheel turned on to open the vent?
    What year is the car?

    Dec
     
  6. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    Yes, the wheel is in the up position and I can see that the vents are open.

    It's 1995.
     
  7. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,469
    Joined:
    Jul 28, 2004
    Car:
    C180,A. September '97 48k
    Could you put up a picture of the area of your dash like the area in picture below?

    Dec

    [​IMG]
     
  8. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    Sure. Here it is:

    [​IMG]
     
    1 person likes this.
  9. Trickythemerc

    Trickythemerc Hardcore MB Enthusiast

    Messages:
    698
    Joined:
    Feb 1, 2015
    Location:
    South Manchester
    Car:
    CLK 220 CDI Sport 2009
    Could be a blend flap motor failed, I think there may be a reset using a combination of button presses that resets the flaps. Try a search on here for it
     
  10. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    To clarify one thing: it isn't that the centre vents aren't blowing at all, but the airflow is very very weak. It can barely be felt by holding my hand directly in front.
     
  11. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,469
    Joined:
    Jul 28, 2004
    Car:
    C180,A. September '97 48k
    I wonder is the right hand air direction dial working, its set at 8 o’clock, any change if you turn it to say 4 o’clock?

    Are the side vent air flow strong when motor is on full blast at setting 5?

    Dec
     
  12. neilrr

    neilrr MB Club Veteran

    Messages:
    6,047
    Joined:
    Jul 20, 2004
    Car:
    Various.
    It's winter here, how can you tell if the AC works?

    Are you in the Southern hemisphere or is this another of those wind up threads?
     
  13. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    I've actually tried all positions - still hardly any coming from the centre. The side vent air flow is strong even at setting 5. At a high setting, e.g., 3+, there is certainly louder sound of airflow behind the centre vents though.
     
  14. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    By AC, I actually meant to encompass both cool and hot air.
     
  15. neilrr

    neilrr MB Club Veteran

    Messages:
    6,047
    Joined:
    Jul 20, 2004
    Car:
    Various.
    Right.
     
  16. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,469
    Joined:
    Jul 28, 2004
    Car:
    C180,A. September '97 48k
    Will the recirculate button, with engine running, make any difference… bottom of the four buttons with car image?


    Was the heater control unit ever removed recently?

    Dec
     
  17. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    The recirculate button doesn't seem to work too well - the light doesn't come on straight away, but after 10-20mins. But even when the light comes on, there's still no difference. I've tried other buttons too.

    No, the control unit was last moved probably 4, 5yrs ago.
     
  18. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    I'm not sure if these are vacuum lines, but is it normal to have a few connectors not hooked up? Here's what mine looks like:

    [​IMG]
     
  19. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,469
    Joined:
    Jul 28, 2004
    Car:
    C180,A. September '97 48k
    Lines look normal, if one wasn’t plugged in then it would be hanging loose somewhere, example of another C180 1994 below.

    [​IMG]


    When the heater control unit is removed, sometimes it is not put back properly, sometimes one or both of the 2 pegs on the rear of the unit are not re-inserted correctly into there respective tubes. If that is the case then correcting this issue might have a bearing on your problem, however, both pegs might indeed be in place and aren’t the cause of your fault, so you might be wasting your time checking this out.

    The only way to check is to remove the unit, slowly, to see if both pegs are indeed in their tubes. When the right dial is turned, the air distribution is altered by the 2 pegs.
    There is some removal information about halve way down this page under Wood Trim and Climate Control, note, not your particular model see here… With this post


    Dec

    [​IMG]

    [​IMG]

    [​IMG]
     
  20. OP
    OP
    mun35

    mun35 Member

    Messages:
    33
    Joined:
    May 21, 2011
    Car:
    C200
    Thanks for the guide. I'll definitely give it a try if nothing else helps. I've just found this post NO AIR BLOWING FROM CENTER VENTS - MBWorld.org Forums

    The guy said (apologies for caps):

    What's "the block"?

    He also said:

    Hopefully my situation is as straightforward as his! But what might these "black valves" and the "block" be?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.