Air conditioning temperature

Malcolmx92

Active Member
Joined
Sep 24, 2013
Messages
125
Car
W211 E63 AMG
Hi,
Hope we are all fit & well.
I’ve bought a cheap project 2007 s211 e280cdi.
Had the air con regassed yesterday.
But I’ve noticed the centre vents are blowing two different temperatures.
I’ve set the temp to the coldest setting & the centre right vent & right window vent are blowing 10c while the left centre & left corner one are blowing 6c…
I’ve checked with a thermometer but seemed to getting to different readings…
I can physically feel 2 different temperatures are blowing…
This can’t be right!!’

The rear centre vents blow the same temp as the front drivers side…

How strange?
Anybody come across this & is there a fix?

Thanks for your help in advance…
 
Last edited:

Ted

MB Enthusiast
Joined
Feb 26, 2004
Messages
6,437
Location
Bourton on Dunsmore
Car
Lexus RC300h F-Sport, Yamaha XVS 1100, Jeep Renegade
On maximum cold you should see around 4 deg C from the face outlet.
how are the individual temp controls set?
there should be a way of resetting all flaps on this - I’ve done it on a couple of my Mercedes but don’t know the procedure for yours but a forum/google search may help 👍🏼👍🏼👍🏼
 
OP
OP
M

Malcolmx92

Active Member
Joined
Sep 24, 2013
Messages
125
Car
W211 E63 AMG
On maximum cold you should see around 4 deg C from the face outlet.
how are the individual temp controls set?
there should be a way of resetting all flaps on this - I’ve done it on a couple of my Mercedes but don’t know the procedure for yours but a forum/google search may help 👍🏼👍🏼👍🏼
I’ve had a little look online but cannot find anything that shows how to reset flaps…

Hello peeps I am @ a loss…
 

Petrol Pete

MB Enthusiast
Joined
Nov 11, 2016
Messages
8,163
Location
Petrol stations ...everywhere
Car
C55 AMG Wagon
Maybe one of the flam actuator motors has broken its linkage , this was common (ish) on older cars where the plastic link would go brittle and crack . The parts were pennies but the labour cost in removing the entire dashboard to get to them is horrendous.

I have been in a 2004 W203 C class with this problem and you can hear it try to home the actuators a few times then it gives up. Can you hear any 'clicking' from behind the dash when you turn the ignition on ?

 
OP
OP
M

Malcolmx92

Active Member
Joined
Sep 24, 2013
Messages
125
Car
W211 E63 AMG
Hi,
Took it to my local expert mechanic…Have been informed it’s more than likely flap is stuck in one position…
Video below👍
 

Users who are viewing this thread

Top Bottom