Anyone finding CoPilot Satnav software buggy?

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
I'm using the 'facelift' version of the popular CoPilot satnav software on an Android smartphone (Samsung Galaxy S2), and after using this updated version for the last couple of months I have been appalled at how buggy it seems to be. The previous version was quite stable but this newer version crashes all over the place and seems to lose the GPS fix frequently (ventilator grille-mounted). The software had to be restarted countless times today and had me swearing at it frequently...grrrrr!!!

Anyone else noticed this regression in stability?
 
OP
OP
ItalianTuneUp

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
I'm using version 9.5.0.440 on S2, Android 4.1.2

Maybe other users can chip-in with their experiences?

I should do a google search next, but just thought of it now and thought I'd see what others' experiences were.
 

Halcyon Days

Active Member
Joined
Sep 4, 2013
Messages
293
Location
Somerset
Car
CLK 350 Sport
South Somerset - we have hills ;-) lol
 
OP
OP
ItalianTuneUp

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
Well, after a cursory search, I found a few other users complaining:

https://forum.copilotlive.com/copil...0_flashing_screen_on_every_turn_losing_signal

ALK employee said, 4 days ago:

"We are aware of this issue with the sreen flashing with Backlight on near turn in power saving mode, and we are looking to resolve it in the next update, but we don't have an ETA of when the next update will be."

This is of interest relating to crashing too:

https://forum.copilotlive.com/copilotlive/topics/not_impressed_want_my_money_back

"1) Crashing: is usually down to a lack of device memory. Can you please try to restart your device before using CoPilot and quit other heavy apps during the navigation? Does it work better now? If not, please inform us when the app crashes so we can check further. Which devices are you using?"

It is true that my S2 has some kind of issue relating to RAM/storage running low, so I will need to look into this further before I blow a gasket.

This looks to be of interest too:

https://forum.copilotlive.com/copil...t_start_up_on_samsung_galaxy_s2_android_4_1_2

"...I assume you are running sufficient amount of available Program memory on your device to eliminate a memory issue. Please note we have thousands of customers who are running the update withou the same issue."
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
8,585
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
I had a lot of problems with it on my S2, it crashed, would not navigate properly etc, I reinstalled it a couple of times and it did improve, you cannot just remove the software though, you also need to delete a folder called com.alk.copilot.......before re-installing

It is more stable on my S4 with the latest version of Android 4.3. the Co-Pilot version is 9.5.0.440
 
OP
OP
ItalianTuneUp

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
Thanks for this. I will try zapping it and deleting the folder you mention, and the doing a reinstall.

If it's still a PITA, then I will consider what to do... new phone, bigger memory? I think I hear a S4/5 calling out... ;)
 

Halcyon Days

Active Member
Joined
Sep 4, 2013
Messages
293
Location
Somerset
Car
CLK 350 Sport
Is your phone normally very stable? have you ever reset it? Do you remove the apps that you don't use anymore?
ummmmmm... What version of Android are you running?
 
OP
OP
ItalianTuneUp

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
> Is your phone normally very stable?

Normally, yes.

> have you ever reset it?

Probably not.

> Do you remove the apps that you don't use anymore?

Generally, yes.

> What version of Android are you running?

4.1.2

However, recently there has been some kind of issue with the SD card. I suspect it has become corrupted, as it fails to install app updates for some apps installed on it, which is not right. I suspect some kind of CRC error due to bit rot or similar. I probably need to reset the phone and install a new SD card, or format the existing one again and reinstall the apps/data stored on it, at the very least.
 
Last edited:

Halcyon Days

Active Member
Joined
Sep 4, 2013
Messages
293
Location
Somerset
Car
CLK 350 Sport
Yes, to all of the above ;-)
remove card. Reset phone.
Don't install anything except CoPilot
See if it works?
 
OP
OP
ItalianTuneUp

ItalianTuneUp

MB Enthusiast
Joined
Nov 20, 2013
Messages
1,356
Location
Hampshire
Car
S320CDI
OK, I'll have to give that a try and see if it fixes the problem. Thanks for the tips!
 

Users who are viewing this thread

Top Bottom