Battery reconnection after storage

Page may contain affiliate links. Please see terms for details.

Twistedmind

Active Member
Joined
May 30, 2013
Messages
594
Location
Staffordshire
Car
Mercedes C350e
Good morning all

i have tried to reconnect my battery after standing the car for 4 months

Following problems have occurred

EBS,ESP, BAS ect

No, wipers, jets

Only one headlight is working and thats at full beam

just a mountain of faults.

Large amount of damp and mould in the car too.

Any advice ???
 
Is the reconnected battery just flat? It'll still lose it's charge even disconnected.

Seems most likely as cars go bat**** crazy when the voltage is low...
 
no battery is fine, tested and charged.

Temp on the dash is reading 85 degrees outside temp too

just gone nuts
 
no battery is fine, tested and charged.

Temp on the dash is reading 85 degrees outside temp too

just gone nuts

Purchase a dehumidifier and dry it out. What you say the battery is fine and you tested it. What do you mean by fine?
 
Garage tested, only a year old as well

Front battery checked too

Is the ECU under the passengers footwell carpet? Thats where the damp is

looking on the net for the control unit that controls the wipers and head lights
 
i take it the front passenger sam controls the dipped headlights, wipers and jets ??
 
Good morning all

i have tried to reconnect my battery after standing the car for 4 months

Following problems have occurred

EBS,ESP, BAS ect

No, wipers, jets

Only one headlight is working and thats at full beam

just a mountain of faults.

Large amount of damp and mould in the car too.

Any advice ???
Any rodents been chewing on the wiring ? Hope not for your sake !

If its been in the damp maybe hiring an industrial heater then a dehumidifier (the type plasterers use) might help.

Good luck.
 
cheers all
dried out the small sam unit in the passenger footwell. got most things back apart for the brake fault. what is the larger black box next to the small sam unit?

Just been through a pre mot while trying to sort the brake issues, needs front brake pipes and suspension welding. might be time to say goodby to the old girl on ebay
 
Could be low voltage or SBC at the limit of use cycles. Star diagnostic would be the way forward.
 

Users who are viewing this thread

Back
Top Bottom