Blocked dpf bank 1 lamba sencor problem

Discussion in 'Engine' started by Efc, Mar 26, 2016.

  1. Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    Hi every 1 sorry if this is in the from place I have a c200 cdi sport 10 plate the engine light was on and of for a few days then stayed on so took it to a mate to plug in comes back with DPF blocked no other codes so booked it in to get a terra dpf clean week later fella plugs it in on the day comes back with dpf and bank 1 lamber sencor as well plus a reading of 30 psi witch was very high so he said to get Merc to plug it in as I could be wasting my money on the dpf clean of if it needs the lamba and a air/ pressure sencor Now every 1 I have spoke to have said the lamba sencor will come on if the dpf is blocked ?? So was thinking get the dpf clean / unblock done and get him to reset all the codes and go from there Merc want £170 to just plug in clean in £200/£250 so fort try that or am I wasting my money sorry for the long post any help at all will be grateful thanks
     
  2. DieselPete

    DieselPete Active Member

    Messages:
    87
    Joined:
    Dec 20, 2015
    Car:
    Mercedes ml 270 - BMW330d
    Before you go spending any more money have you checked the 2 pipes to the diferential sensor ? It could be blocked giving you the fault. Try diconecting the pipes and blow out with low pressure air line. Also make check all the wiring is ok it could be burnt if running close to the exhaust.
     
  3. OP
    OP
    Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    Thanks for that bit of info
     
  4. OP
    OP
    Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    Took the car back to day the dpf is clear no lamba sensor code was on thy was testing all the pressures and test on the wires thy have said its lost the earth wire to the pressure sensor and needs chaesing back to were it gone that's why it's comming back with diffrent codes has any 1 got any info on this sort of problem it's going in to a auto spark Tomoz any help on this problem would be great thanks
     
  5. DieselPete

    DieselPete Active Member

    Messages:
    87
    Joined:
    Dec 20, 2015
    Car:
    Mercedes ml 270 - BMW330d
    If the spark has a wiring diagram he should find the problem easily. It could be rubbed through or corroded. Pls let me know how he gets on. I love this type of fault
     
  6. OP
    OP
    Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    Thanks Pete hopefully it's an qick and easy job and the earth wire has just come lose or rubbed though let you know what the out come is apparently mercedes have a common wireing loom fault
     
    Last edited: Mar 29, 2016
  7. OP
    OP
    Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    Well the wireing is sound the auto spark Said it's the sensor that needs replacing its not sending signals so 2 weeks later going round in circles could of been a sorted in 1 day £60 part £30 labour that sound about right ?
     
  8. DieselPete

    DieselPete Active Member

    Messages:
    87
    Joined:
    Dec 20, 2015
    Car:
    Mercedes ml 270 - BMW330d
    Yep sounds fine to me labour rate is very cheap imo.
     
  9. OP
    OP
    Efc

    Efc New Member

    Messages:
    6
    Joined:
    Mar 24, 2016
    Car:
    C200 sport
    He's a freind of a freind so fingers crossed its sorted Tomoz
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.