bluetooth sync sumsung omnia

Discussion in 'Electronics' started by ngjarman, Sep 26, 2008.

  1. ngjarman

    ngjarman New Member

    Messages:
    1
    Joined:
    Sep 26, 2008
    Hi,
    I have just bought a Samsung Omnia 900i phone. I can't get it to sync with the bluetooth handsfree in my C-Class - latest model.
    Does anyone know how to resolve this?
    I don't recall any trouble with my previous phone, an HTC TYNII
    cheers, Neil
     
  2. evdok

    evdok Hardcore MB Enthusiast

    Messages:
    2,519
    Joined:
    Sep 26, 2006
    Location:
    Stourport
    Car:
    BMW 330D xDRIVE M/SPORT INDIVIDUAL
    Welcome to the forum, ;)

    Make sure the omnia is visible enabled to other blue-tooth devices.
     
  3. partsspecialist

    partsspecialist Hardcore MB Enthusiast

    Messages:
    411
    Joined:
    Jul 22, 2008
    Location:
    Bolton/Manchester
    Car:
    Ford Focus TDCI
    Hi, ive had this problem with a few phones where it fails to authorise.
    On the menu in the car where you can search for phones, go right into options and select external authorisation. The screen will display 'awaiting external authorisation'. While in this mode you can use your phone to search for new devices and it will see the car. Put the same passcode into the car and the phone and it should work fine.

    Regards
     
  4. evdok

    evdok Hardcore MB Enthusiast

    Messages:
    2,519
    Joined:
    Sep 26, 2006
    Location:
    Stourport
    Car:
    BMW 330D xDRIVE M/SPORT INDIVIDUAL
    phone might be too new..:confused:
     
  5. gmatj

    gmatj Active Member

    Messages:
    83
    Joined:
    Jun 14, 2008
    Location:
    Athens, Greece
    Car:
    E200K Avantg.Facelift MY2007,Auto,Sunroof,Heated Seats,Xenon,Phone,Parktronic,rearview cam,NTG2.5,TV
    Hi All
    I also have a SAMSUNG OMNIA and I have problems using it with COMAND NTG2.5

    In this COMAND all my 3 Ericssons pair fine - work fine.

    However with the Omnia Phone keeps connecting and immediately disconnecting and so on....

    Anybody has found a fix ???? or atleast has found what the problem might be ??

    Rgds
    G,


    P.S. My car E200K MY2007 , with NTG2.5
     
  6. corned

    corned Hardcore MB Enthusiast

    Messages:
    3,894
    Joined:
    May 2, 2008
    Location:
    Living in error with Maude at Cap Ferrat
    Car:
    car
    My Omnia (8910i) has no connectivity issues with COMAND, but mine is MY2005 so I am certain this is a different version.

    Once you have paired, have you set the MB BT to 'trusted' (or 'authorised' - whichever) on the phone?
     
  7. gmatj

    gmatj Active Member

    Messages:
    83
    Joined:
    Jun 14, 2008
    Location:
    Athens, Greece
    Car:
    E200K Avantg.Facelift MY2007,Auto,Sunroof,Heated Seats,Xenon,Phone,Parktronic,rearview cam,NTG2.5,TV
    My Omnia is 900i and the Bluetooth is in NTG2.5 COMAND.
    (Before when I had the NTG1 with and HFP module I had NO problems)

    In i900 there is no option to set MB BT to trusted - Once it is initially authorised it should always be)

    Still puzzled !!!!

    P.S. What COMAND model are you using ??
     
  8. corned

    corned Hardcore MB Enthusiast

    Messages:
    3,894
    Joined:
    May 2, 2008
    Location:
    Living in error with Maude at Cap Ferrat
    Car:
    car
    Not entirely sure. I think it's NTG2. Also I am using the MB SAP V2 puck connected in the pre-wire arm rest.

    I think we're coming from circumstances which are too different for me to offer any really useful or relevant advice, unfortunately.

    I know that it should remain authorised once this has been done, but have you re-checked? I know mine very occasionally seems to lose it's way and asks for the SIM PIN, so the only advice I can offer is to go back to step one and start afresh.

    After that, I'm afraid, I'm stuck. :eek:
     
  9. gmatj

    gmatj Active Member

    Messages:
    83
    Joined:
    Jun 14, 2008
    Location:
    Athens, Greece
    Car:
    E200K Avantg.Facelift MY2007,Auto,Sunroof,Heated Seats,Xenon,Phone,Parktronic,rearview cam,NTG2.5,TV
    You are correct.
    COMAND NTG2.5 which I am refering to, has BT incorporated within the unit. (I mean the COMAND itself has BT capability for connection with up to 10 phones!!).
    It not an external add-on such as SAP / HFP craddles such as in your case, and in mine when I previously had the NTG1 COMAND with an HSP craddle connected in the pre-wire arm rest and everything was working fine.
    So I have to search further !!!
     
  10. JohnRML350

    JohnRML350 New Member

    Messages:
    1
    Joined:
    Oct 4, 2010
    Samsung Omnia - contacts not showing up

    I have a Samsung Omnia i910 and a 2008 ML 350. I believe I have the SAP V2 adapter.
    The contacts (address book) is not populating.
    Has this issue been figured out?
    Please HELP!

    Thanks,
    John


     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.