Brake Discs problem mercedes w222

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Time came for my front brakes
Ordered genuine parts, within 1000miles noticed vibration at steering wheel while braking, mercedes issued another set
This time within 700 miles vibrations returned
Part number for discs was A2224215000
Loosing my mind a bit with this one
Did a bit of digging and found another part numbers for discs in question A 222 420 01 72, A2224215100, A2224200272
Hoped MB dealer will provide suitable part for my car
Vin is WDD2220322A037836
Could someone advise?
Thanx


Sent from my iPhone using Tapatalk
 

richard

Authorised Forum Sponsor
SUPPORTER
Joined
Jun 10, 2002
Messages
6,341
Location
Berkshire, UK
Car
MY04 SL55, MY18 GLC63s
According to Parts catalogue using your chassis number, front disks are A222 420 01 72 and must be replaced in pairs.

R
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Thank you
Looks like got wrong discs on the car then



Sent from my iPhone using Tapatalk
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,860
Car
Lexus RC300h F-Sport 2019
Make sure the hub/disc mating surfaces are scrupulously clean before fitting. Slightest bit of muck or rust will throw the disc out of true, eventually causing vibration under braking.
 

optimusprime

MB Enthusiast
SUPPORTER
Joined
Dec 29, 2013
Messages
4,012
Location
Kidderminster Worcestershire UK
Car
Mercedes W124 260E M103
Borys Can i ask who the dealers isw that fitted your discs . Working on yourr vin number misups like this should never happen..
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Make sure the hub/disc mating surfaces are scrupulously clean before fitting. Slightest bit of muck or rust will throw the disc out of true, eventually causing vibration under braking.

That was all done when fitted second time by my indy, was with him at the workshop.
It started vibrating after 700 miles


Sent from my iPhone using Tapatalk
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Borys Can i ask who the dealers isw that fitted your discs . Working on yourr vin number misups like this should never happen..

First time it was fitted abroad by MB dealer in Poland. Trip by to UK vibration started
Second set supplied by MB NewCastle-same part number ending 5000
Fitted by my indy as mentioned - 700 miles vibration came back

I did ask today supplying dealer if part numbers got something to do with it. They replied

Hi,

The part number A2224200172 is superseeded by A2224215000, The one we have supplied is the new version of your discs as the do not make this part number A2224200172 anymore.

Regards




Sent from my iPhone using Tapatalk
 

optimusprime

MB Enthusiast
SUPPORTER
Joined
Dec 29, 2013
Messages
4,012
Location
Kidderminster Worcestershire UK
Car
Mercedes W124 260E M103
I think maybe you have other problems that cause this . You can rule this disc out . Mercedes make lots of changes over the years , but the item dimensions never change as far as brake discs go. And if they did other parts that marry up to them would not work together.
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Yes you probably right
Need to investigate further


Sent from my iPhone using Tapatalk
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
To refresh this tread maybe some wisdom from fellow members will help
Today car started to vibrate while braking again, this is after trip to Brugge and back
So far we went through 3 sets of discs and pads, new front wheel hubs with bearings, whole front suspension is new
At this point I’m starting to loose my mind on this


Sent from my iPhone using Tapatalk
 

markjay

MB Master
SUPPORTER
Joined
Jun 24, 2008
Messages
32,799
Location
London
Car
W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
I had this issue on my Vauxhall Omega some years back, sadly never got to figure it out.

Vibration felt through steering wheel when braking.

Changed front discs and pads, and also fitted new wheel hubs and bearings at the same time. Used new caliper bolts. I fitted everything myself and was very thorough in terms of cleaning parts and tightening to torque etc. Initially all was fine, but the problem came back two months later.

The possible causes I was looking at at the time were failed suspension component (I bought two new wishbones but never got around to fitting them before trading-in the car), or issue with the rear brakes.

Good luck with sorting it out.
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
We checked that, piston moves nice and free


Sent from my iPhone using Tapatalk
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
Each time it takes around 1000 miles for the problem to come back, after fitting new discs and pads
Each time after longer trip around 500 miles



Sent from my iPhone using Tapatalk
 

AMGeed

MB Club Veteran
SUPPORTER
Joined
Nov 1, 2008
Messages
15,263
Location
Bournemouth/Poole Dorset
Car
2014 E63 Biturbo
After the number of disc/pad changes and other work you have done, I'd call it day and either p/x the car or replace the discs/pads again and sell it before the problem returns.

Not the answer you want to hear, but that would be my route.
 
OP
OP
Borys

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,765
Location
Nowe nad Wisla
Car
2005 cl500
After the number of disc/pad changes and other work you have done, I'd call it day and either p/x the car or replace the discs/pads again and sell it before the problem returns.

Not the answer you want to hear, but that would be my route.

Thinking exactly the same thing


Sent from my iPhone using Tapatalk
 

zipdip

MB Enthusiast
SUPPORTER
Joined
Mar 5, 2015
Messages
3,583
Location
Essex
Car
s320
Don't sell it just yet,I am about to try and solve a very similar problem,like you have changed discs and pads,like you the problem goes away,I will try something different in the next couple of weeks,I will return :)
 

ToeKnee

MB Enthusiast
SUPPORTER
Joined
Aug 14, 2016
Messages
1,565
Location
leicestershire
Car
R230 SL500 in teal blue, R231 SL500 in black. Vauxhall insignia diesel
Can you get/borrow a dial gauge and check the disk run out? If it is still true then pointless changing them again (try cold and hot after a run if possible). That might help eliminate one aspect?
 

Users who are viewing this thread

Top Bottom