C Class W204 passenger side Wiper blade hitting Scuttle

Discussion in 'Parts, Maintenance & Servicing' started by dellyend1, Feb 12, 2020.

  1. dellyend1

    dellyend1 New Member

    Messages:
    4
    Joined:
    Feb 8, 2014
    Car:
    R129 SL 500
    Dear All,

    I've got a 2009 C Class that has wipers replaced at its last service. The passenger side wiper blade end (last 2 cm) is now knocking the top of the scuttle plate. Is there a way of adjusting the wiper arm to stop this. I've checked the wiper blade length and i think it is correct and loathed to cut it shorter to miss the scuttle plate as it may then travel even further down the screen.

    Any thoughts advice appreciated

    Best Wishes

    Jeremy
     
  2. cws196

    cws196 Hardcore MB Enthusiast

    Messages:
    269
    Joined:
    Jan 4, 2013
    Car:
    S205 C43 Estate
    CowleyStJames likes this.
  3. alecmascot

    alecmascot Hardcore MB Enthusiast

    Messages:
    368
    Joined:
    Mar 16, 2016
    Location:
    North East UK
    Car:
    C220 CDI 57 plate
    Yes,a puller will make things easier,
    There are little alignment marks silk screened onto the windshield.
    Use them to set up the position.
    But the real question is : why did things change ? Something is wrong.
     
  4. OP
    OP
    dellyend1

    dellyend1 New Member

    Messages:
    4
    Joined:
    Feb 8, 2014
    Car:
    R129 SL 500
    Hi, thank you both for the replies. I've ordered the removal tool. Can I ask though, what could go wrong ? I have full functionality, smooth wipers etc . It's just the passenger one has too much of a sweep and drops below the bonnet line. As part of the service do the wiper arms ever get removed and such it is a case of a non alignment / correct positioning when they were re-installed ? Best Wishes. Jeremy
     
  5. alecmascot

    alecmascot Hardcore MB Enthusiast

    Messages:
    368
    Joined:
    Mar 16, 2016
    Location:
    North East UK
    Car:
    C220 CDI 57 plate
    No
     
  6. MrGreedy

    MrGreedy Hardcore MB Enthusiast

    Messages:
    183
    Joined:
    Jan 13, 2020
    Location:
    Leicestershire
    Car:
    Insignia diesel :-( and w212 E350 CDI :-)
    I had this on a W203 at about 12 years old. Only thing I could put it down to was some very tiny movement on the spindle.

    Of course, I snapped one of the spindles whilst I was doing the job, so I needed to buy a new (used) wiper linkage to replace the broken spindle!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.