[SOLVED] C200 CDI (2004 203K): Fault Code P2015

Discussion in 'Engine' started by pjatkin, Jun 7, 2011.

  1. pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    My C200 is constantly going into limp mode (3000 rpm max) after 5 minutes of driving and putting on the MIL light with OBD Code P2015(2015, Intake Manifold Runner Position Sensor/Switch Circuit Range/Performance).

    Any ideas what the problem might be?

    Note: the MAF sensor and EGR seem to be working OK. Furthermore the ECU and turbo have been refurbished. None of the above has made any difference.

    Thanks in advance

    PeteA
     
  2. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    Id say its the Intake Manifold Runner Position Sensor/Switch!!

    Seriously though its a little motor on the manifold, common fault.
     
  3. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    Thanks for your quick reply.

    I did have a look in my Haynes manual, but it didn't mention the Intake Manifold Runner Position Sensor/Switch...

    Do you know what it looks like (an image if possible) and where it would be?

    Thanks once again

    PeteA
     
  4. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    Its on the underside of the intake manifold and controls the little flaps on the manifold. note that the flaps/arms may well be seized or broken.
     
  5. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    Last edited: Jun 8, 2011
  6. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    Thats the top of the engine, the small flaps are on the underside of the manifold.
     
  7. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    Thanks,

    I'll take off the manifold over the weekend and have a look

    PeteA
     
  8. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    good luck!
     
  9. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    OK, I found the motor arm and exercised it a few times.

    The good news is that I don't get the P2015 error code any more...

    The bad news is that I now get the following:

    P0102: Mass or volume air flow circuit low input
    P0243: Turbo/supercharger wastegate solenoid A
    P0489: Exhaust gas recirculation control circuit low
    P2009: Intake Manifold Runner Control Circuit Low
    P2102: Throttle Actuator Control Motor Circuit Low

    Could this be a defective motor?

    PeteA
     
  10. Justin1600

    Justin1600 Hardcore MB Enthusiast

    Messages:
    2,077
    Joined:
    Dec 28, 2010
    Car:
    C43 AMG
    You need to connect a Star Diagnosis machine and actuate the inlet port shut off motor. If the motor under the manifold or the rods to the flaps don't move, then you need to disconnect the motor from the rods and see if the rods move freely.
    If not you will need a new inlet manifold and the shut off motor :thumb:
     
  11. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    You have blown a fuse now by messing with it so none of the systems in that circuit are working... you need to replace the motor and find the blown fuse.
     
  12. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    Thanks again jaymanek

    I'm in the process of removing the inlet manifold - what a job...

    Its not quite out yet (rain stopped play) but I can already see that its full of cr*p.

    I looked for a fuse in the manual but couldn't see anything suitable. Any ideas which fuse?

    PeteA
     
  13. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    it will be one of the ones in the engine bay fuse box. Sorry dont know exactly which number off the top of my head.
     
  14. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    OK, got the inlet manifold out now.

    All the flaps are functioning correctly so I'm assuming its the motor thats at fault.

    I have tried a few places (Dingbro, Unipart, GSF) but other than MB, any idea where I can get a replacement part (A 611 150 04 94 021 - or Pierburg 72264414 B4 107)?

    Is there any way I can test the motor?

    PeteA
     
    Last edited: Jun 10, 2011
  15. OP
    OP
    pjatkin

    pjatkin New Member

    Messages:
    13
    Joined:
    May 28, 2011
    Car:
    C200 CDI
    Fuse 53 in the engine bay fusebox had blown (15A).

    I've now replaced the fuse and fitted a new motor to the inlet manifold (about £150) and reassembling everything.

    Touch wood everything now seems to be working OK.

    Here's some images of the inlet manifold: Mercedes C200 203 (2004) - a set on Flickr

    Thanks for your help

    PeteA
     
  16. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,358
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    Well done, glad its sorted.
     
  17. eugekav

    eugekav Hardcore MB Enthusiast

    Messages:
    145
    Joined:
    Apr 14, 2011
    Location:
    Ruislip,Middlesex.
    Car:
    mb w211 estate
    Must be good

    Hi,Must be good to get a solved label.I am hoping to get the same.Could or would you tell me where you got the mechanical drawing featured in your picture's, this must be such a help:thumb:Thanks in antisipation.

    Euge.
     
  18. gdenny

    gdenny New Member

    Messages:
    1
    Joined:
    Sep 24, 2015
    Car:
    R129 500SL & C350 CDI
    Where did you get the motor from?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.