C200 Electric Cooling Fan

Discussion in 'Engine' started by JohnnyW202, Sep 23, 2011.

  1. JohnnyW202

    JohnnyW202 Hardcore MB Enthusiast

    Messages:
    146
    Joined:
    May 22, 2011
    Car:
    2004 Mercedes E270CDI Elegance Saloon, 2004 C200 Kompressor Estate Avantgarde SE Sport Pack
    Hi there,

    I'm just a bit concerned, since everything else is peachy at the moment..

    Under start stop driving or after heavy acceleration my car can get as high as the fourth mark on the temperature guage, as I understand it the M111 should stay at 85c constantly, when I'm driving along on the motorway etc it does, but occassionally it gets higher, Particularly if I drive the car, get out briefly and get back in the temperature seems to briefly go higher, until moving.

    Recent Water Pump, Thermostat Etc.

    The Fan comes on when the A/C is on.

    I've never heard/seen it go on once then temperature gets above 85c, the car never gets past the 4th mark even on a hot day, so it never overheats as such, which would be the 5th mark at 120c.

    Interestingly enough when I pull the plug off my MAF, the fun runs at a constant high speed, that I've never exhibited my car do when all is fine and well, there's plenty of power and the maf is cleaned often so I don't think there's an issue with it.

    Could it be the infamous relay control near the passengers wheelarch?

    Many Thanks, is it something to worry about?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.