C200 heater woes.

Bladerunner

New Member
Joined
Oct 5, 2003
Messages
6
Location
Tamworth,Staffs
Car
C200
My '98 C200 has recently developed a strange squeaky / squealy sound from the heater-blower which I suppose, is the start of a bigger problem. I have seen a well photographed article by "Shude" on heater motor removal. If I removed my motor, any suggestions as to what I should look for / clean / lubricate, or does it look like I need a new unit ? :confused:
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Originally posted by Bladerunner
My '98 C200 has recently developed a strange squeaky / squealy sound from the heater-blower which I suppose, is the start of a bigger problem. I have seen a well photographed article by "Shude" on heater motor removal. If I removed my motor, any suggestions as to what I should look for / clean / lubricate, or does it look like I need a new unit ? :confused:

As it is Autumn, have you checked that there are no leaves in the air inlets. This may not be as strange as it sounds, as I had that problem on my 190E.:confused: :confused:
 
OP
OP
B

Bladerunner

New Member
Joined
Oct 5, 2003
Messages
6
Location
Tamworth,Staffs
Car
C200
Thanks Brian, I will check that first. Incidently, how do you get your photo(s) at the end of your message ?
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Originally posted by Bladerunner
Thanks Brian, I will check that first. Incidently, how do you get your photo(s) at the end of your message ?

For signature & Other Photos see

Photos

For signature - go to user control panel-edit profile, under signatures add wording and http link to photo, but it must be no bigger than 300 x 125
 

Users who are viewing this thread

Top Bottom