C200K nearly stalls when braking

Discussion in 'Engine' started by steve pratt, Mar 11, 2017.

  1. steve pratt

    steve pratt Member

    Messages:
    30
    Joined:
    Jan 22, 2016
    Car:
    c200 kompressor estate
    Hi,
    My 53 plate C200k Automatic nearly stalls when coming to a stand still. Sometimes if i accelerate from stop and brake immediately the engine appears to hunt and oscillate for a few seconds gradually decreasing. There is also a slight vibration at tick over now when in drive but not in neutral.
    Split vacuum pipe under air cleaner was replaced recently which has solved the erratic tick over.
    Any ideas please.
     
  2. ernie

    ernie Active Member

    Messages:
    457
    Joined:
    Apr 3, 2006
    Location:
    Scotland East
    Car:
    C Class, W205 Sport 2018
    Check the remaining vacuum pipes, particularly around the servo. Does the servo hold the vac after the engine is switched off? I.e. after say half an hour and you press the brake pedal, does it go solid after a few presses, or is it solid immediately? This might point to a faulty servo.

    On the other hand, it could be something unrelated which might show up if the fault codes were checked.

    Ernie
     
  3. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,898
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, E55 AMG, S500, etc
    There is also a breather pipe and a one way valve under the inlet manifold that splits. Needs a Star to read codes and data.
     
  4. OP
    OP
    steve pratt

    steve pratt Member

    Messages:
    30
    Joined:
    Jan 22, 2016
    Car:
    c200 kompressor estate
    thanks for input. the breather pipe and valve were split and changed before Xmas which cured the erratic idle nicely. This vibration is as though the tick over in drive is too low as it disappears in neutral as the idle increases slightly. Is there any idle adjustment i can do. I cleaned the throttle body last summer but maybe an air filter change could help now?
     
  5. ernie

    ernie Active Member

    Messages:
    457
    Joined:
    Apr 3, 2006
    Location:
    Scotland East
    Car:
    C Class, W205 Sport 2018
    As above, you really need to have the codes read. Something is wrong that is causing your idle problem and until that is done, you could be spending money unnecessarily.

    Ernie
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.