C220 CDI Coupe Possible electric problem

Discussion in 'Electronics' started by irish1759, Apr 14, 2014.

  1. irish1759

    irish1759 New Member

    Messages:
    9
    Joined:
    Apr 14, 2014
    Car:
    c220 cdi coupe
    Hi Guys,
    I am a new member, recently bought my first Mercedes a 2002 C220 CDi Coupe, and i must say it is a pleasure to drive.
    Some problems i am have though is with the electrics, i have noticed the radio keeps turning off on its own, also the electric windows don't work when the radio cuts out and sometimes the orange light on the airbag It does happen all the time and when i stop at the traffic lights it seem to all work again. Tonight while driving home and all the above happened i also noticed the lights on the steering wheel flicker on and off, my headlights seemed to flickers a little and somethings when changing lane the indicators arrows who be slightly slower.
    I must also point out i have a dipped headlight needs replacing and the sensor for the auto lights is faulty they are the only to malfunctions on the dashboard.

    Could it be these two that is causing the rest to go all funny or has anyone else come across this too..
     
    Last edited: Apr 14, 2014
  2. mersum1es

    mersum1es Hardcore MB Enthusiast

    Messages:
    1,056
    Joined:
    Aug 9, 2012
    Location:
    Finland
    Car:
    W220, W210
    Sounds undervoltage / grounding problem to me...

    measure battery and check all visible leads around the battery; then check no water in fuse box/SAM units...
     
  3. OP
    OP
    irish1759

    irish1759 New Member

    Messages:
    9
    Joined:
    Apr 14, 2014
    Car:
    c220 cdi coupe
    Thanks for the reply, I'll check over all the leads when I get a chance. Also may sound like a stupid question but what is and where is the SAM unit??
     
  4. Rigkraft

    Rigkraft New Member

    Messages:
    14
    Joined:
    Apr 5, 2014
    Car:
    mb cdi 220 coupe
    I wish I could offer you some advice but I cant , I would like to say thank you though as you have made my leccy problems seem much more trivial ,

    Shane

    also a new member with a 220 cdi
     
  5. OP
    OP
    irish1759

    irish1759 New Member

    Messages:
    9
    Joined:
    Apr 14, 2014
    Car:
    c220 cdi coupe
    Lol, I'll let you know if I solve it.
     
  6. Dave Richardson

    Dave Richardson Hardcore MB Enthusiast

    Messages:
    764
    Joined:
    Oct 14, 2007
    Location:
    Plymstock Plymouth
    Car:
    C Class 220 Evo CDI
    The front SAM or fuse box as we used to call it is under the bonnet drivers side & is held closed with two spring clips close to the bulkhead, once the lid is removed you can expect to see a whole load of fuses & relay units

    Good luck, new sam is IRO of £200 & you'll need the car reset on a Star machine after fitting

    Dave
     
  7. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    As said, check all earth and positive leads and also make sure the sam isn't wet.
     
  8. OP
    OP
    irish1759

    irish1759 New Member

    Messages:
    9
    Joined:
    Apr 14, 2014
    Car:
    c220 cdi coupe
    Right had a look at the battery seems fine looks new with no corrosion. SAM box look good to nice and clean and dry inside. Run the motor and turn it off but was a little nice that ran for few seconds by the coolent box there is a little black component in front of it. Not sure if that normal
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.