C220 S204 Estate (W204) Right Hand Side cold, LHS warm

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
Heres an interesting one. My lovely (UK: Right hand drive estate) 2011 C220 S204 has decided to chill the driver whilst keeping the passenger cosy warm. It's not the Air con. No error messages on dash or through the Diagnostics reader (icarsoft).
The chill feels like external air. I'm thinking blend flaps but here's the puzzle: the rear passenger compartment vents (the ones at the back of the armrest) ALSO have warm air out of the left vent and cold air out of the right vent. (a puzzle because I thought the rear passenger compartment was not able to have left and right temparature adjustment.)
If I press the recirculator button the drivers side windscreen foggs up quickly.
Air con clears the screen and does its usual thing on both sides.
Of course no amount of turning up the heat (on either side) has any effect on the drivers side. Seat heater works fine though Thank God!
(Other things I think are irrelevant but perhaps should be taken into account: Comand screen is blank, functions (except sat nav of course) work fine. I had a leak of a litre of w/washer fluid in the rhs passenger footwell GRR. The car has done 165Kmiles)
 
OP
OP
J

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
Further to this: There is now an error code pointing to the right blend flap actuator. Sounds right.
There is no electrical access from the CAM to the actuator : all the actuator readings are N/A
To me this looks like an electrical fault with the wires to that actuator.
With the Comand screen failure I am now thinking we have a return of our friendly electrics-eating rodent.
And today the remote central locking has stopped working, thank god for the infra red drivers door access.
So I am getting multiple electrical faults probably caused by severing of wires.
 
OP
OP
J

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
The remote central locking problem turned out to be a fuse: Rear fusebox fuse number 46. Phew.
 
OP
OP
J

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
Yes it seems clear that it's rodent damage now.
damaged_connector_bfe91504fffabcf648a7aecbb857702fb82fb82a.png

W204 Right hand drive. behind the dash. Air box.
The copper wire to the COMAND screen was gnawed and the connector highlighted here is damaged too.
Can anyone tell me what this connector (the little one pointed to by the arrow) is for?
It seems to be a 3 wire (only) connector pretty hard to get to with normal sized hands!
 
OP
OP
J

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
Yes, every wire to the right side Air Blend actuator is severed.
Does anyone know how to unlock and remove the connector? WIN_20220126_14_23_13_Pro.jpg WIN_20220126_13_27_53_Pro.jpg
 
OP
OP
J

JulianB

New Member
Joined
Jun 18, 2017
Messages
15
Car
c220 2011 204
Yes it seems clear that it's rodent damage now.
damaged_connector_bfe91504fffabcf648a7aecbb857702fb82fb82a.png

W204 Right hand drive. behind the dash. Air box.
The copper wire to the COMAND screen was gnawed and the connector highlighted here is damaged too.
Can anyone tell me what this connector (the little one pointed to by the arrow) is for?
It seems to be a 3 wire (only) connector pretty hard to get to with normal sized hands!
This connector is fixed now thanks to very long handled pliers. I also made a cover with a pin to press in the small hole on the left hand side. i am unsure whether this actually made a difference but the connector popped out with the pliers on the left and right sides.
 

Users who are viewing this thread

Top Bottom