C250 cdi new Jan 24

Discussion in 'Engine' started by CHOD, Mar 17, 2013.

  1. CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    My c250 cdi has only done 3100 but engine diagnostic light is on and engine temperature is running at around 85-90 - never ran low on fuel
    Of course with it being Sunday no Merc service departments are open!
    I have a journey of around 10 miles to nearest one tomorrow morning but does anyone have any ideas if it should be driven there or collected?
    The manual says to take it in but doesn't feel to good to drive just now.
     
  2. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    85º - 90º is normal temperature. 90º being the ideal.

    Any other clues? Any other lights on?
     
  3. OP
    OP
    CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    No other lights on thanks
     
  4. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    Any stored error messages? (Instructions on access and reading them should be in the handbook).
     
  5. OP
    OP
    CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    Will go and look
     
  6. OP
    OP
    CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    No messages stored
     
  7. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    You may find that the light goes out of it's own accord or you may get a message to give you a clue as to what, if any, the problem could be. If it was serious you would probably get a STOP warning.
    Should be ok to drive I would think.
     
  8. OP
    OP
    CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    Ok thanks

    I will take in in morning
    Cheers
     
  9. Ted

    Ted MB Club Veteran

    Messages:
    5,577
    Joined:
    Feb 26, 2004
    Location:
    Bourton on Dunsmore
    Car:
    SLC 250D AMG Line, Yamaha XVS 1100, Jeep Renegade
    Spam reported
     
  10. st4

    st4 Banned

    Messages:
    14,374
    Joined:
    Mar 1, 2008
    Location:
    In the driving seat
    Car:
    C220cdi tourer
    Drive it and take it in on Monday, the lights usually come on for something?
     
  11. OP
    OP
    CHOD

    CHOD New Member

    Messages:
    8
    Joined:
    Dec 17, 2012
    Car:
    C250
    Just an update for reference took car in yesterday regarding engine diagnostic light on received back today cause was – ‘Rear rail pressure sensor, suspect connector / connection – cleaned up replaced and all ok’ - pretty good service received as well from service team at Merc Aberdeen
    Thanks for help
    C
     
    2 people like this.
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.