C32 AMG seems to be using coolant :(

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
As the title, my C32 seems to have developed a bit of a thirst for coolant. I've dug around on here and my scenario seems to be the same as others, no visible leaks and it isn't using loads, but a pint of water in a month (doing maybe 400 miles in that time) is still more than it should use, if any at all! I have previous history showing that the car had the rad/gearbox glycol problem sorted out, so I'll rule that one out. I've only really glanced around the engine bay, underneath and can't see any signs of leaks, so I'm thinking maybe I'll check under the plenum chambers for dried coolant stains, to see if it is the charge cooler playing up. If anyone has removed these before, are there/will I need new gaskets or if they have rubber ones are they reuseable?

Thanks for any help, this is the only 'fault' with the car and it's disappointed me somewhat from what is otherwise a wonderful car.
 

jonathanc

Active Member
Joined
Nov 18, 2007
Messages
98
Location
Marlborough
Car
E270 Avantgarde Estate
Hi Gaz

As somone who has just been through the same thing, the gasket is a cork one so you need to replace it - abbout £5 from MB. Takes about 10 minutes to remove, check and replace. Just need to take off the engine cover and the relevant air box - I took the right hand side (drivers) as it doesn't have the oil breather pipe behind it which can come off if you are not careful.

Hopefully it is not the intercooler leaking. On mine it would lose coolant intermittently, none for ages then suddenly the coolant light came on. I took the planeum covers off and, to my relief, there was no sign at all of coolant. I beleive it was the expansion chamber cap, I thik the spring was weak and would allow coolant out at certain temps. I hope this is the case for yours to.

Cheers
 

calgonis

Active Member
Joined
Sep 22, 2009
Messages
97
Location
St Leonards on Sea
Car
C230 Sold / 69' VW Devon Delux camper / BMW M135i
Hi Gaz,

When I was changing the intercooler pump (access via the front wheel arch) I noticed in my struggle that a coolant pipe near too to the intercooler pipes (it's not directly connected but on the left side of the wheel arch opening) was leaking coolant (I think I stressed the a joint against the back of my hand while trying to get the intercooler pipes on). The pipe has a join in it where the leak appeared to drip from when touched.

When I sent the car to a garage to have them test and refit the new pump a day later I told them about the suspected leak from the other pipe. They assured me that the coolent I had seen leak had come from the intercooler pipe and the other pipe was fine.

Reading your thread here I would view this pipe as being almost guaranteed to be the one you are losing coolant from. Glad you are enjoying the car - hope you get a speedy fix now you know!

Andrew
 
OP
OP
Gaz74

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
Hi Andy! I'm well pleased with the car, you must be missing it! I'll get the car on a ramp this week then and have a look at those pipes, thanks for the heads up :)

The car has been a joy to live with, I haven't done too much to it since I bought it. Only things I've done are to change the sidelight bulbs to LEDs, had a de-cat pipe fitted (sounds lovely now!) and today I had 4 new Contis and a full geometry set up done over at Wheels in Motion and it feels much better on the road, that pull to the left is now gone!

:)
 
OP
OP
Gaz74

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
Quick update:

I had the coolant system pressure tested for a couple of hours by my local indy and they could find no visible leaks. I kind of wish they had, because it would have been an easier fix than what it could now be :( I can only assume that if there are no visible external leaks, then it's burning off coolant internally somewhere. After the pressure test, the indy topped up the expansion tank to the max and after a couple of weeks and around 500 miles, it's down to half way. Not good.

However, it's not puffing white smoke and the oil appears to be fine, so it might not be a head gasket failure. Still, gonna be costing some £££, whatever it might be :(
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
9,087
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Ask your garage to carry out a test for combustion products in the coolant, if there are then it is a head gasket and it is better to find that out now and hopefully catch it before it warps badly and cannot be easily fixed.
 
OP
OP
Gaz74

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
I will do soon, fingers crossed it won't be the HG
 

AMGry Man

Member
Joined
Jan 23, 2010
Messages
59
Location
Solihull, West Midlands
Car
Present: C250 CGI AMG Sport Coupe, Previous: C250 CDI AMG Sport Coupe (1 yr), C32 AMG Estate (5yrs)
Hi, It may be the intercooler; I went through the whole head gasket tests just to show a negative; think they have to take the kompressor off to check.
Thankfully mine was under warranty....
 

misfire84

Active Member
Joined
Jan 1, 2010
Messages
105
Location
Wales
Car
w204 250 GDI estate and hers c270cdi, c32,
what radiator do you have as the early ones have a sealing problem putting coolant in to the autogearbox fluid .
 
OP
OP
Gaz74

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
HG tests came back fine, no CO2 in the coolant. The rad had previously been changed due to contamination, so it's not that either.
So, the finger points to the intercooler which is all that can be left. Oh well, more £££ flying out of my wallet.... :(
 

jonathanc

Active Member
Joined
Nov 18, 2007
Messages
98
Location
Marlborough
Car
E270 Avantgarde Estate
Hi Gaz

It is really easy to take of the plenum chamber cover and check, if it is the intercooler then you'll see the deposits all on the intake tracts - if it isn't clean metal then it is the intercooler. The other indicator will be excessive steam from the exhausts in the morning - this will be the coolant from the intercooler being vaporised.

Hopefully some other explanation accoutns for the loss of coolant but otherwise its going to be a big bill I am afraid:( I think the part is about £900 from Merc, Acid may be able to get a discount on that? I am not sure if it might be cheaper to get the same part from Chrysler in the states as the crossfire SRT6 uses the same engine? Might be worth looking at the US crossfire sites - there might be an alternative. I am not sure if anyone has approach Garrett (who make the part) directly, maybe cheaper.

Cheers
 
OP
OP
Gaz74

Gaz74

Active Member
Joined
Jun 12, 2011
Messages
217
Location
Herts
Car
C32 AMG
I'll have a look under the plenum covers then to see if anything shows up. Fingers crossed....

Thanks to all who have offered advice :)
 

dmp

New Member
Joined
Nov 6, 2014
Messages
24
Location
Honiton Devon
Car
2004 E55 Saloon - 2003 C32 AMG Estate - Sold
As the title, my C32 seems to have developed a bit of a thirst for coolant. I've dug around on here and my scenario seems to be the same as others, no visible leaks and it isn't using loads, but a pint of water in a month (doing maybe 400 miles in that time) is still more than it should use, if any at all! I have previous history showing that the car had the rad/gearbox glycol problem sorted out, so I'll rule that one out. I've only really glanced around the engine bay, underneath and can't see any signs of leaks, so I'm thinking maybe I'll check under the plenum chambers for dried coolant stains, to see if it is the charge cooler playing up. If anyone has removed these before, are there/will I need new gaskets or if they have rubber ones are they reuseable?

Thanks for any help, this is the only 'fault' with the car and it's disappointed me somewhat from what is otherwise a wonderful car.

Gaz hi

I have a similar issue. Did you resolve yours?
Regards
David
 

dmp

New Member
Joined
Nov 6, 2014
Messages
24
Location
Honiton Devon
Car
2004 E55 Saloon - 2003 C32 AMG Estate - Sold
Ernie

No idea. I had recently renewed the coolant which perhaps had some effect. Seems to have settled now.

Best

David
 

Users who are viewing this thread

Top Bottom