C36 Misfire/rough idle advice please.

Discussion in 'Engine' started by cazyp, Jul 4, 2011.

  1. cazyp

    cazyp Active Member

    Messages:
    266
    Joined:
    Oct 23, 2010
    Car:
    C43, Hilux
    Just recently the C36 has developed a slight misfire - more noticable on idle than when driving. The rev needle fluctuates just a tiny amount - about 100 to 200 rpm.

    It is worse on warm starting - although the car starts fine - it idles rougher when warm.

    No fault codes showing.

    I'm going to change the spark plugs but any ideas where to look then? Don't want to go down the route of random replacements of parts if I can help it.

    Many thanks.

    On a side note on the MOT - which it passed - it only just came down below the CO2 limit. Could this be related? o2 sensor?
    Thanks
     
  2. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,922
    Joined:
    Feb 8, 2007
    Location:
    Portsmouth, Hampshire.
    Car:
    E55K SL500 E300Hybrid E250X3 Viano C55 E450Cab A180 Smart 44 Brabus
    Fault codes don't mean much in this case. The live data needs to be checked. Plug into a star and have a look at the smooth engine running menu. This will guide you to what cylinder could be missing.

    Also check the maf and llambda values to make sure they are ok.
     
  3. horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    what millage has it on her

    check fuel pressure at the fuel rail and clean the fuel rail filter

    leave the star test running when you do this also check the oxygen sensor when the engine is running the reading should be moving up and down

    i had this on my c36 turned out to be a faulty injector

    if you have a spare maf swap and check

    also i know the car can take three types of plugs as it says on the sticker under bonnet
    but the bosch always worked best for me not the champion or breu

    check ht leads for wear and also dont move the wire harness to much as could become brittle with age and you could cause more trouble

    keep us posted
     
  4. OP
    OP
    cazyp

    cazyp Active Member

    Messages:
    266
    Joined:
    Oct 23, 2010
    Car:
    C43, Hilux
    I checked all the vacuum pipes - one was loose at the front - seems to have dome the trick!:thumb:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.