C43 AMG MOT fail on emissions HELP

Page may contain affiliate links. Please see terms for details.

waisal

Member
Joined
Jan 31, 2016
Messages
38
Location
North West
Car
W202 C43 AMG
Hello

I had my MOT today on my W202 C43 and failed due to emissions. I have had a stainless exhaust with middle CAT and box delete done about 3 months ago the CATs were past it anyway.

Anybody in similar situation is there any fuel additive or other technique I can use to get through emissions.
 
What were the readings? Which failed? No2, Co or lambda? You should have got a test result sheet back with the mot fail

Sent from my SM-N9005 using Tapatalk
 
Hi,
I had the same exhaust mods as you have on my C43 and it would fail the emissions if it hadn't been used regularly. As it was my weekend car, so I just used it for the commute for a week before the MOT and it would pass no problems.
 
my car is a daily driver so used almost daily
according to MOT certificatedialed due to excessive CO but no reading given
I will add some cataclean and go for a longish drive before retest

Sent from my SM-G935F using Tapatalk
 
Are the lambda sensors working ok?
 
Both my pre cat lambdas are faulty and no engine warning light, it's worth getting them checked with a diagnostic machine.
 
Did the retest failed again due to CO 0.6 should be 0.3 need to check lambda sensors now.

I think going down the CAT delete route these days is potentially going to make things difficult at MOT time
 
Last edited:
Are they using a probe to put in the tail pipe? Excessive CO is probably cats as their function is to turn CO to CO2. If you're not getting a check engine light and they are using a probe then there's your problem.
 

Users who are viewing this thread

Back
Top Bottom