C43 Engine mount knock

Discussion in 'Engine' started by omegav6i, Jun 25, 2014.

  1. omegav6i

    omegav6i Hardcore MB Enthusiast

    Messages:
    152
    Joined:
    May 9, 2010
    Location:
    Hoddesdon
    Car:
    C43
    I was geting a loud metalalic sounding knock coming from the front of the car when going over bumps and changing inclines in roads. When checked out i was told the suspension looks fine but the engine is moving around on the mounts quite alot so this was more than likely causing the problem.

    Had the engine and gearbox mounts changed and all was perfect, engine idling better etc but a day later i have noticed the same sort of knock, the only thing is its alot quieter and takes quite a bit more to set it off.

    Is it normal for the mounts to make a noise on harsher bumps? the car is on 18'' wheels and no1 pads, or is it most likely yet another trip to the garage is in order?
     
  2. Twistedmind

    Twistedmind Hardcore MB Enthusiast

    Messages:
    594
    Joined:
    May 30, 2013
    Location:
    Staffordshire
    Car:
    Mercedes C350e
    Lower ball joints

    Sent from my iPhone using MBClub UK
     
  3. OP
    OP
    omegav6i

    omegav6i Hardcore MB Enthusiast

    Messages:
    152
    Joined:
    May 9, 2010
    Location:
    Hoddesdon
    Car:
    C43
    This was the first thing they said it could be when they took the car but apparently every thing was fine.

    It sounds like whatever it is that clunks, then clunks again and again like something is loose and swinging about.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.