C63 Exhaust Problem

Discussion in 'AMG Lounge' started by No11zyy, Sep 4, 2017.

  1. No11zyy

    No11zyy New Member

    Messages:
    2
    Joined:
    Sep 4, 2017
    Car:
    Mercedes C63 2014 Saloon
    Hi Guys,

    First post here and sadly it's an issue with my C63 :(

    Only been a month since I bought the car and all of a sudden the exhaust growl isn't the same, just sounds like not like a c63 and hint of power loss too! Had an indie look at it and an Xentry diagnostic but came back with zero faults.

    Any ideas what this could be? The car is 2014 saloon with only 29k on the clock.

    Cheers,
    Sam
     
  2. sirius9

    sirius9 Hardcore MB Enthusiast

    Messages:
    759
    Joined:
    May 8, 2010
    Car:
    C63 Saloon
    Sound clip?

    Is it on start up? Or when revving?

    Difficult to offer opinion or advice when there is not much specific info.
     
  3. OP
    OP
    No11zyy

    No11zyy New Member

    Messages:
    2
    Joined:
    Sep 4, 2017
    Car:
    Mercedes C63 2014 Saloon
    Sorry here is a link to hear the exhaust https://youtu.be/I9unJHqqexM

    This is on cold start and sounds a little normal here but the grows fade away..

    Also when driving along can barely hear the exhaust almost sounds like something is blocked.
     
    Last edited: Sep 5, 2017
  4. Alpinaman

    Alpinaman Active Member

    Messages:
    69
    Joined:
    Apr 24, 2017
    Car:
    Mercedes C63 AMG.
    Sounds normal to me...
     
  5. JohnBell

    JohnBell Hardcore MB Enthusiast

    Messages:
    385
    Joined:
    Mar 12, 2016
    Car:
    A handful of Amg cars.
    And me.
     
  6. JDL60

    JDL60 Hardcore MB Enthusiast

    Messages:
    1,041
    Joined:
    Apr 17, 2015
    Location:
    Wirral
    Car:
    BMW i8
    And me too
     
  7. Neiltodd

    Neiltodd Hardcore MB Enthusiast

    Messages:
    592
    Joined:
    Jul 22, 2009
    Location:
    moray
    Car:
    c63 amg estate
    me too
     
  8. Robdata

    Robdata Active Member

    Messages:
    74
    Joined:
    Apr 14, 2014
    Location:
    Oxfordshire
    Car:
    C63 2013
    Nothing wrong with that. Like myn
     
  9. sirius9

    sirius9 Hardcore MB Enthusiast

    Messages:
    759
    Joined:
    May 8, 2010
    Car:
    C63 Saloon
    Sounds normal to me as well.

    Have you flick between C mode and S+ mode? Different throttle opening can give different exhaust tone.

    It might be that after 1 month, you kinda got used to the loud tone already. Time for secondary decat and a remap??
     
  10. Black Scorpion

    Black Scorpion Hardcore MB Enthusiast

    Messages:
    140
    Joined:
    May 11, 2017
    Location:
    North East
    Car:
    AMG C63
    That sounds normal to me.
    Like already said if you switch from C to S to S+ you get different exhaust tones.

    Drive it and enjoy it.
     
  11. JimmyR

    JimmyR Member

    Messages:
    37
    Joined:
    Jul 19, 2017
    Car:
    W212 E63S
    You are just growing used to it. Nothing to worry about. To confuse you further though there has been a TCU/ECU software update released in the past 12 months or so. I had it installed at a routine MB service a few months ago on a 2013 C63 and there is quite a difference particularly in the way the transmission behaves but also subjectively at least more exhaust noise (upshift blips in S/S+) and crackles/pops on high rpm over run.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.