C63 Lumber Supports

MMacD

New Member
Joined
May 10, 2016
Messages
18
Car
c63
Hey,

I've had my car in at Mercedes to try and identify and resolve the issue with my seat lumber supports.

It's not been working for a couple of months so I checked all the fuses with no issues found, put it into the dealers to get further checks done and they are struggling to find the fault. They're confident it's not a wiring issue and the main unit was changed out but still the issue persists. The cars 2013 with a 2 year extended warranty when I bought it from Mercedes.

Any ideas?


Sent from my iPhone using Tapatalk
 
Last edited:

Gledsyc63

Active Member
Joined
Jul 20, 2014
Messages
142
Location
Halifax
Car
2012 c63 amg 14 amarok canyon
Try fuse 56 in the rear fuse box. 5 amp not even listed in the diagrams as anything to do with the seats. Mine keeps blowing I think I've got a short in the wiring on the seat somewhere.


Sent from my iPhone using Tapatalk
 
OP
OP
MMacD

MMacD

New Member
Joined
May 10, 2016
Messages
18
Car
c63
Sorry, my mistake! It's very much still open.


Sent from my iPhone using Tapatalk



That's what keeps going on mine. The problem is if it's a wiring issue they've said it's not covered under the warrant and I can expect a bill of £550!


Sent from my iPhone using Tapatalk
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,614
Car
Lexus RC300h F-Sport 2019
Do you move the seat back and forth a lot? I'd check the loom and connectors underneath for loose pins and or chaffed wires
 
OP
OP
MMacD

MMacD

New Member
Joined
May 10, 2016
Messages
18
Car
c63
Do you move the seat back and forth a lot? I'd check the loom and connectors underneath for loose pins and or chaffed wires



Not really..the garage just called to say they've fixed it, and the works covered by the warranty. I'll find out the issue tomorrow.


Sent from my iPhone using Tapatalk
 

Users who are viewing this thread

Top Bottom