C63 strange steering behavior?!

Discussion in 'AMG Lounge' started by Jamesyc63, Mar 15, 2019 at 12:58 PM.

  1. Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    My 2013 C63 has he driver package with lane assist etc. where it does a slight vibrating through system if you drift between lanes on motorway without indicating, i have driven cars with lane assist before and thats all fine and as to be expected and good.....


    However.... i still get the lane assist type vibrations through the steering wheel when driving around town and cornering not even on a motorway. Its very strange. Its a bit like the vibrating you get with lane assist is coming thro wheels into the steering wheel.

    I've noticed this is mainly when accelerating - so if you are going quick and corner without foot on pedal its fine, as soon as you put foot on pedal for some power it vibrates - not in a balancing way, feels just like a harsher lane assist!! Bit like driving on ice kind of feeling!!

    I have turned off lane assist altogether, changed tyres from 40 to 36psi but still the same.

    Would be delighted to get rid of that if possible??? :)
     
  2. Iggu

    Iggu Active Member

    Messages:
    93
    Joined:
    Feb 4, 2017
    Car:
    C63 AMG
    Just replied to your other thread without seeing this. Are you sure you don't have car hypochondria? If there is something wrong with the car you must get it checked out professionally but these are pretty much bullet proof machines so I'm hopeful this is all just in your mind (understandable if you are a new owner but just relax and enjoy if possible).
     
    Jamesyc63 likes this.
  3. rOckyC63

    rOckyC63 Hardcore MB Enthusiast

    Messages:
    283
    Joined:
    Apr 28, 2017
    Location:
    Surrey
    Car:
    C63 AMG 507
    @Jamesyc63 Check the air in the tyres and the w204 has a stuff suspension very hard.
     
    Jamesyc63 likes this.
  4. Yex

    Yex Hardcore MB Enthusiast

    Messages:
    127
    Joined:
    Jul 24, 2018
    Location:
    South Essex
    Car:
    C63AMG Edition 507, TVR Chimaera 450, Range Rover Evoque
    As above check the tyre pressures, I run 38 front and 42 rear and the car handles beautifully and I have the uprated suspension on mine. Also consider getting the geometry checked as it is quite sensitive on these cars.

    If the car is doing anything you feel is strange take it to a main dealer or recommended specialist and get it on the STAR diagnostics system to see if any error codes come up. My car has all the electronic driving aids you can imagine and behaves perfectly so to put your mind at rest get a few checks done :)
     
    Jamesyc63 likes this.
  5. Gnasher141

    Gnasher141 New Member

    Messages:
    15
    Joined:
    Nov 7, 2018
    Location:
    Hertfordshire
    Car:
    C63 W204
    Try getting wheels balanced and checked for trueness. Had this with mine and front inner wheel was buckled a good 20mm out of true.

    Wheel repaired - all good
     
    Jamesyc63 likes this.
  6. Greenmanslk

    Greenmanslk Hardcore MB Enthusiast

    Messages:
    506
    Joined:
    Apr 7, 2017
    Car:
    SLK (172)
    Checked your wheel nuts are tight?
     
    Jamesyc63 likes this.
  7. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    Thanks guys appreciate it.

    Maybe tyres are crap?

    Will try and get it on a star machine. Anyone know of a specialist near brighton or gatwick?

    I changed pressure from 40 all round to 36 all round.

    If im on the power there is definitely some kind of vibe coming through the steering wheel.

    Hadnt even though of the wheel nuts, jesus! Better check them!!

    The steering has always been quite heavy (not light power steering with one finger job) and suspension hard which i like but this feels like its skipping along the road on ice!
     
  8. rOckyC63

    rOckyC63 Hardcore MB Enthusiast

    Messages:
    283
    Joined:
    Apr 28, 2017
    Location:
    Surrey
    Car:
    C63 AMG 507
    What tyres are on the car?

    I would look in the fuel cap and use the PSI described in there. Note there is different PSI for summer and winter tyres and alloy size.

    Also, how much tread on the tyres? Also worth checking for cracks as someone mentioned earlier!
     
    Jamesyc63 likes this.
  9. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    Will check the tyre brands im pretty sure the treads are all at least half their life or more.

    Would a crap brand or non matching brand cause this much aggro?
     
  10. rOckyC63

    rOckyC63 Hardcore MB Enthusiast

    Messages:
    283
    Joined:
    Apr 28, 2017
    Location:
    Surrey
    Car:
    C63 AMG 507
    Yes, it would.
     
  11. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    Hmm ok will check that first tomorro and report back
     
  12. Lee C63

    Lee C63 Hardcore MB Enthusiast

    Messages:
    1,532
    Joined:
    Apr 20, 2013
    Location:
    Newcastle
    Car:
    C63 (weistec supercharged)
    Seems strange if the vibration is only when you are “on power” so no vibration if your coasting?
     
  13. markjay

    markjay MB Club Veteran

    Messages:
    20,531
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    The 'Rumble Strip' effect is caused by an electric motor that vibrates the steering column when Lane Assist is triggered.

    If this happens however when Lane Assist is switched off, then this can only be a malfunction and you'll need to take the car to the dealer to get it diagnosed on STAR.
     
  14. markjay

    markjay MB Club Veteran

    Messages:
    20,531
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    Jamesyc63 likes this.
  15. markjay

    markjay MB Club Veteran

    Messages:
    20,531
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    You have a C63 and you do not know what brand of tyres are on the car..........?
     
    Greenmanslk likes this.
  16. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    Hi yeah thats the only way i can describe the feeling like that electrical motor vibration only when on power and turning the wheel not coasting
     
  17. Gnasher141

    Gnasher141 New Member

    Messages:
    15
    Joined:
    Nov 7, 2018
    Location:
    Hertfordshire
    Car:
    C63 W204
    Get the wheels and tyres balanced. At least you can rule that out, for less than £20. Then go from there, to 4 wheel alignment check.
     
    Jamesyc63 likes this.
  18. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    I know hands up! Been too busy enjoying it.

    This may be a good sign tho. Both good tread On the fronts but One is an eagle F1 and one is a Neolin Neosport - never heard of it. And why oh why are they not matching

    First port is change the fronts to a matching decent brand and get wheels balanced and 4 wheel alignement and see from there i guess yeah!!!
     
    Yex and Neiltodd like this.
  19. OP
    OP
    Jamesyc63

    Jamesyc63 Active Member

    Messages:
    73
    Joined:
    Feb 18, 2019
    Location:
    South
    Car:
    C63
    Cant actually believe that tyre is on there. 2 new fronts going on monday!!! Will report back with hopefully positive news. Thanks guys
     
  20. Greenmanslk

    Greenmanslk Hardcore MB Enthusiast

    Messages:
    506
    Joined:
    Apr 7, 2017
    Car:
    SLK (172)
    fixe
    all fixed yet ?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.