Car Looses Power (Many Mechanics Later, still the same Issue)

Page may contain affiliate links. Please see terms for details.

Alexn

New Member
Joined
Oct 10, 2023
Messages
2
Location
Glasgow
Car
E220 Estate 2015
Hi Everyone,

I was driving and the car lost power, I was only able to go into 2nd and 3rd gear and the car wouldn't accelerate.

I was abroad (in Poland) , so, I reached out to a mercedes approved garage and I got billed for

  1. oil kit
  2. xbrake cleaner
  3. flow meter
  4. throttle m316
  5. service inspection entry in dsb
  6. xentry omatic short test
  7. throttle replacement
  8. Replacement air flow meters
  9. "adaptation"
I got the car back and, drove a couple miles and i got the issue again, got the car to the same garage, they replaced a valve (can't say which one, I don't have the bill at hand). Drove a couple miles and got the exact same issue, so I bought a Carly OBD device and got the following error codes.

Under CDI (CDI 6) Common Rail Diesel Injection and CDI (CDI D) Common Rail Diesel Injection

  1. P010337
  2. P012315
  3. P211271
  4. P22F92
  5. P220F77
  6. P012315
I also got ADS-Adaptive Damping System and PTS-Parktronic (N62)
  1. C156684
  2. C156884
  3. U016887

I gave the car to another mechanic and I was told that he checked the
  1. Engine Pistons
  2. Cleaned the DPF filter
  3. Checked Injectors
No issues found, however, I have now driven a couple of miles and when the car is slowly accelerating and passing 2nd 3rd and 4th gear it jumps so, I put carly ack again and got

2x CDI (CDI 6 Common Rail Diesel Injection) and 1x CDI (CDI D) Common Rail Diesel Injection Issues

  1. P012315 - Position sensor 1 for the throttle valve has a short circuit to positive. There is a short circuit to positive or an open circuit. / -Position sensor 1 for the throttle valve has a short circuit to positive. There is a short circuit to positive or an open circuit. / The position sensor 1 of the throttle valve has a short to positive. There is a short to positive or an interruption.
CGW [ZGW] Central Gateway
  1. B210A00 - The power supply in the system is too low.
Transmission
  1. P2600 - 026 The coding for component B41/1 (Front passenger seat occupied recognition) is faulty. / 026 Unknown fault code / 026 Currently no fault text available
  2. P0028 - Generic communication fault code
  3. U3FC1 - Generic communication fault code - Not defined - Not defined

Any chance, anyone has an idea of what this could be?

Thank you.
 
has the battery/alternator been checked? this can throw up some strange unrelated codes?
 
I will check for the alternator, but the battery according to Carly is at 83.0 charge level and discharge per day <5.0 with a state of health that is "Good"
 

Users who are viewing this thread

Back
Top Bottom