car not starting, gears not engaging

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
hi, i purchased a w211 about 2 months ago...and so far i have spent £500!:mad:

But now it seems that i will spend more than that....I took a drive from Leicester to Birmingham (50 miles) in the rainiest weather ever!

Got to my destination and the car would not come off D...No reverse, neutral etc...Switched the car off and could never got it back on again!!! Inside everything works and no errors on the dash.

Had to get it recovered and its now with an indy... anyone experience a problem like this before?

I really hope its not the gearbox...so far i have enjoyed little and spent alot:wallbash:
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
The car will only start in Park or Neutral, if it is Drive there is an inhibitor circuit to prevent you starting whilst in gear, it could be a simple fault with the selector mechanism.

What have you spent the £500 on?
 
OP
OP
Azim

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
The car will only start in Park or Neutral, if it is Drive there is an inhibitor circuit to prevent you starting whilst in gear, it could be a simple fault with the selector mechanism.

What have you spent the £500 on?
hi, is there a way of resetting this mechanism? i am under the impression that i seen something that can be reset with a pen?

the £500 was spent on:
-service at dealer
-replace rear spring
-replace MAP and DPS sensors - the car was in limp mode but the sensors didnt help... motorway journey seems to have allowed DPF to regenerate and issue sorted
diagnostic of above
-spray to prevent the car rusting underneath
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
There is an emergency selector release but this is generally used only if it is stuck in Park as there is a solenoid that keeps the lever locked in Park until you press the footbrake.
 
OP
OP
Azim

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
There is an emergency selector release but this is generally used only if it is stuck in Park as there is a solenoid that keeps the lever locked in Park until you press the footbrake.
its not engaging in park but the car rolls so its nto stuck in D although that was the case when the car was switched on....I guess i have to wait until tomorrow when my mechanic plugs it into STAR

are these cars generally like this? always have issues ?
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
It sounds like the gearbox has moved to neutral but the lever has stuck before it can move to a position that would allow the inhibitor circuit to recognise that the lever is in neutral.
 
OP
OP
Azim

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
It sounds like the gearbox has moved to neutral but the lever has stuck before it can move to a position that would allow the inhibitor circuit to recognise that the lever is in neutral.
Is it expensive to fix?
 

Alps

MB Enthusiast
SUPPORTER
Joined
Nov 29, 2002
Messages
7,175
Location
London\Essex
Car
E55 2004 Silver, E63 Weistec AMG(SOLD), E55 2004 Silver(SOLD), C36 AMG 1997 (SOLD)
Earth strap possibly? only saying that as you mentioned driving in rain.

I think you have been unlucky, but service you must have known about before buying the car, just shows its worth getting checked by an indi before buying, hindsight tho hey!

anyhow they are all small probs that are easily fixed.
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
You need to find out why before you can know the cost
There are a number of possible causes
 

MarkJunedd

Active Member
Joined
Apr 10, 2010
Messages
361
Location
Swansea
Car
98 CLK320 Sport
its not engaging in park but the car rolls so its nto stuck in D although that was the case when the car was switched on
It probably is stuck in drive as with out the engine running the transmission has no pressure in it so it will act as if its neutral. And no it wont start if it is in drive (or reverse) because of the inhibitor.
 
OP
OP
Azim

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
It probably is stuck in drive as with out the engine running the transmission has no pressure in it so it will act as if its neutral. And no it wont start if it is in drive (or reverse) because of the inhibitor.
okkk that explains why it isnt starting then...well i understand these are all assumptions for now.... the car has been serviced at merc every year since purchase so it has full MB Service history.
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
i just pray its not a major issue...is the gear put back to normal via STAR or physically?
As said previously get a diagnosis of the problem then you will know what is involved in fixing it
 
OP
OP
Azim

Azim

Member
Joined
Jun 11, 2012
Messages
43
Location
Leicester, UK
Car
2005 E320 CDI W211
problem solved.....took it to the indy and he put it into STAR and it said that there was an issue with the transmission...checked it and it was the transmission rod that had come loose because a pin had broken or not fitted in properly back again after working on the transmission (Mercedes did do a job on the transmission before :mad:)....£55 and its all up and running...#
Thanks everyone
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
It sounds like the gearbox has moved to neutral but the lever has stuck before it can move to a position that would allow the inhibitor circuit to recognise that the lever is in neutral.
problem solved.....took it to the indy and he put it into STAR and it said that there was an issue with the transmission...checked it and it was the transmission rod that had come loose because a pin had broken or not fitted in properly back again after working on the transmission (Mercedes did do a job on the transmission before :mad:)....£55 and its all up and running...#
Thanks everyone
:thumb:
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom