Car starts the electrics fail

Scottbo

New Member
Joined
Jan 11, 2011
Messages
9
Location
Lincoln
Car
E320 CDI
Please help.. I had a new battery fitted to my E320 cdi (211) a few weeks ago as I was getting the visit workshop battery light. All has been well however last week I started the car and it was fine. I then stopped to fill up and when I started the car, non of my electrics worked (except the radio), this includes ,speedo, rev counter, indicators etc. I drove for about 5 miles then pulled over and I noticed that it hadnt even recorded the mileage on my mileometer. I turned the car off an waited a while and when I restarted everything worked. This has now happened at least 10 times this week and I dont know where to turn, soetime it cn tak eme 10 restarts to get everything working, simply put I either get everything working fine or, the engine starts but no electrics aside from the radio and lights work. I have replaced the batterys in he key incase it was not registering properly. Any suggestions>
 
Last edited:

Rdublin

New Member
Joined
May 7, 2013
Messages
4
Car
C180 kompressor
Did you find the solution to this problem mate ? I have the same problem now I think. Sometimes my fob key doesn't work and sometimes it does but when it does I switch the ignition on and all electrics work but once car is started all electrics are gone clocks indicators etc ... Cheers
 

Rdublin

New Member
Joined
May 7, 2013
Messages
4
Car
C180 kompressor
Or would anyone be able to help me ??
 

MC68HC705X32

New Member
Joined
Nov 12, 2011
Messages
17
Car
Vito 115CDi
Rdublin, Its more than likely the Key. What kind of condition is it in?
 

WG M-B

Auhorised Forum Sponsor
SUPPORTER
Joined
May 26, 2011
Messages
1,897
Location
N/W london
Car
C63 Wagon in black
Do you have a warning indicating consumers switched off by any chance???
 

didi w203

Active Member
Joined
Dec 12, 2012
Messages
169
Location
Dorset
Car
merc C220 cdi w203 Coupe
I get that when I leave the car parked for about a week. It comes up in red in the display saying battery voltage low switch off consumables. Then airbag light will come back on, stereo will switch off by itself. I drive it for about an hour and all is well. Check alternator for charging.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom