Central locking question

Steve Riley

Member
Joined
Apr 26, 2003
Messages
51
Location
Blackburn
Car
Merc 190E
Hi Peeps, me again.
My '91 190E has developed this thing where you click the button on the key fob remote and the indicators flash, the horn beeps but the doors don't lock.
The little stick things (techy stuff, huh?) on top of the door panels just quiver a bit but don't go down. When this happens, another press on the remote button unsets the alarm, then another press and it tries to lock again. Sometimes it takes 3 or 4 goes before it actually locks the doors. BTW, it only ever takes one click to UNlock the doors.
Any clues? Haynes on order but may take a week to get here.
Cheers,
Steve
 

Steve_Perry

MB Enthusiast
Joined
Jun 3, 2002
Messages
3,241
Location
Wales, U.K.
Car
CLS350CDI Grand Edition
Might there be a leak on the vacuum lines that drive the central locking? Any noises or hissing sounds?

The only other thing I can think of is the logic unit that governs the central locking might be on the way out.

I presume from your description that all four doors are affected.

Another test to try... try locking the door, the old-fashioned way with the key in the driver's door to see if it then works properly. It could be that the alarm unit has a fault or faulty wiring.

S.
 
OP
OP
S

Steve Riley

Member
Joined
Apr 26, 2003
Messages
51
Location
Blackburn
Car
Merc 190E
Hi Steve,
Using the key in the drivers door to lock the door only locks that door, same with unlocking. Still need to use the fob to turn the alarm on, which seems to work fine.
Steve (Mk2)
 

Steve_Perry

MB Enthusiast
Joined
Jun 3, 2002
Messages
3,241
Location
Wales, U.K.
Car
CLS350CDI Grand Edition
Umm shouldn't the key in the driver's door lock/unlock all doors & boot on the W201? May need a specialist and/or dealership to look at it. I'm out of ideas Steve, sorry.

To me, it sounds like it maybe the logic unit but I'm by no means an expert.

S.
 

Users who are viewing this thread

Top Bottom