charging

jmac200t

New Member
Joined
Aug 24, 2011
Messages
2
Car
c220 w202
Hi i have a w164 2007 320cdi and its not charging but the battery light is not on.
i removed it and gave it to an auto electrician he tested it and gave it a clean bill of health.
anyone have the same problem or similar.:confused:
 

LvR

Member
Joined
Apr 18, 2014
Messages
55
Location
South Africa
Car
A160 W168
The current flowing through the charge problem indicator lamp is responsible for exciting the alternator in most cases ....................... if the actual lamp is blown you will have no charge situation.

Does the lamp ever light up before you start the engine? ........... if not you may have found the problem
 

kid-jensen

MB Enthusiast
Joined
Dec 16, 2002
Messages
1,217
Location
Epsom Downs
Car
ML 320 W164
Have you measured the volts on the battery to confirm it's not charging?

What duid you remove to have checked, battery or alternator?
 
OP
OP
J

jmac200t

New Member
Joined
Aug 24, 2011
Messages
2
Car
c220 w202
Had alternator checked and battery all ok.

Battery light is on when you turn on ignition.

7 volts at battery
 

kid-jensen

MB Enthusiast
Joined
Dec 16, 2002
Messages
1,217
Location
Epsom Downs
Car
ML 320 W164
How long does the battery take to go flat when you're driving?

How does the voltage at the battery change when the engine is running?
 

190

MB Enthusiast
Joined
Mar 4, 2015
Messages
3,297
Location
Cheshire
Car
2009 W204 C180K
7 volts can't be right as the car wouldn't start.
 

David404

Active Member
Joined
Sep 7, 2015
Messages
759
Location
West Midlands
Car
GLE350d (W166)
Try a different multi meter?

Test voltage at the battery with everything switched off.
Start engine, rev a little
Check voltage at battery again

you should expect to see higher voltage with engine running.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom