CL500 2007 Alarm keeps going off

Discussion in 'Electronics' started by Mickcedes, Jun 23, 2017.

  1. Mickcedes

    Mickcedes New Member

    Messages:
    4
    Joined:
    Jan 2, 2014
    Location:
    Southampton
    Car:
    mercedes CL500
    HI guys, any ideas ? 20 secs after locking doors alarm goes off. It is a keyless go 2007 C216 CL500. I have to leave car unlocked over night to stop it !!!!!!
     
  2. KillerHERTZ

    KillerHERTZ Administrator Staff Member

    Messages:
    16,351
    Joined:
    May 21, 2003
    Location:
    Cambridge
    Car:
    CLS63 AMG
    Alarm battery on its way out. Located in front wheel arch (wheel off job) and it comes as a complete unit - around £100. You will need a security torx bit to replace it.
     
  3. optimusprime

    optimusprime Hardcore MB Enthusiast

    Messages:
    2,626
    Joined:
    Dec 29, 2013
    Location:
    Kidderminster Worcestershire UK
    Car:
    Mercedes W124 260E M103
    First before going and purchasing a new battery unit at £100 take a look at the alarm switches on the boot and bonnet for corrosion . There may be some on the doors also.
     
    1 person likes this.
  4. Dord1954

    Dord1954 Active Member

    Messages:
    63
    Joined:
    Jul 8, 2015
    Location:
    Shropshire
    Car:
    CLS 320 CDI
    Hi my alarm failed a couple of weeks ago although symptoms did not point to the siren (I had no sat nav or radio signal all fed from the same fuse as the alarm) I assume that the indicators flash at the same time as the alarm sounding so if you just disconnect the alarm and the lights dont flash after locking the car then I guess it is the siren that is at fault and being as your car is 10 years old (similar age to mine) its a pretty safe bet.
    the siren is quite easy to get at behind the front nearside wheel arch, I think I have a link to instructions somewhere
     
    1 person likes this.
  5. Dord1954

    Dord1954 Active Member

    Messages:
    63
    Joined:
    Jul 8, 2015
    Location:
    Shropshire
    Car:
    CLS 320 CDI
  6. OP
    OP
    Mickcedes

    Mickcedes New Member

    Messages:
    4
    Joined:
    Jan 2, 2014
    Location:
    Southampton
    Car:
    mercedes CL500
    Thanks for info, Ive had consumer battery checked and apparently its been drained quite heavily and just needs a full charge. fingers crossed
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.