cl500 front strut creaking

ianc

New Member
Joined
Mar 19, 2011
Messages
29
Car
CL500
I've an '05 cl500 with about 50k miles on it and the front driver strut has started to creak a lot on any sort of bump. It also does it if I use the dash button to raise or lower the car.

I think I've isolated it to the strut rather than any of the other suspension joints but I haven't taken the protective cover off ot examine inside yet. The strut still seems to be funstioning fine.

Has anyone else had this problem and what did ye do about it?
 

biturbo

Active Member
Joined
May 14, 2009
Messages
605
Location
Cheshire
Car
S600 BiTurbo, SL60 AMG, Landcrapper Disco, Merc sprinter, E320 D6.
What type of system is it? ABC or airmatic?
 

C43AMG

MB Enthusiast
SUPPORTER
Joined
Apr 15, 2005
Messages
7,288
Location
Weybridge. U.K
Car
500L ( W221 ), 2014 AMG CL 5.5 Biturbo ( W216 ) Sold, 2014 Brabus Smart ( 451 Coupe ) Mapped 130bhp
Is it leaking ? If so a new strut.
 
OP
OP
I

ianc

New Member
Joined
Mar 19, 2011
Messages
29
Car
CL500
No leaks
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,796
Location
Portsmouth, Hampshire.
Car
E55K SL500 E250X2 Smart44 Brabus Track car E450Cabriolet X350 Pick up
It is most likely to be the lower ball joint on the hub.
 

biturbo

Active Member
Joined
May 14, 2009
Messages
605
Location
Cheshire
Car
S600 BiTurbo, SL60 AMG, Landcrapper Disco, Merc sprinter, E320 D6.
might be the rubber on the top of the strut. They are the rubbish and perish. they then dont do their job and cause damage to the strut. trouble is, merc dont sell just the £5 rubber part they want to sell you the whole 1k part, typical mercedes that.
 

GlenQ

Active Member
Joined
Jun 16, 2011
Messages
202
Location
Derbyshire UK
Car
2004 W220 S320 CDI
I've an '05 cl500 with about 50k miles on it and the front driver strut has started to creak a lot on any sort of bump. It also does it if I use the dash button to raise or lower the car.

I think I've isolated it to the strut rather than any of the other suspension joints but I haven't taken the protective cover off ot examine inside yet. The strut still seems to be funstioning fine.

Has anyone else had this problem and what did ye do about it?

As Olly has indicated i would take a look at the lower ball joint. I had the creaking you have. If you try to grip the ball joint while someone gently pushes down on the top of the wing above the wheel you will 'feel' the creak of a dry joint. Also check for a cracking to the rubber seal.

I just had my ball joint replaced and now no creaking!
 

GlenQ

Active Member
Joined
Jun 16, 2011
Messages
202
Location
Derbyshire UK
Car
2004 W220 S320 CDI
Nothing
43.gif

There are better ways of getting your post count up.
 
OP
OP
I

ianc

New Member
Joined
Mar 19, 2011
Messages
29
Car
CL500
I got some motorcycle chain lub (runny and penetrating initially and then turns into a sticky greese) sprayed into the ball joint at the bottom of the strut and all squeaks are gone..... for the moment.
 

Users who are viewing this thread

Top Bottom