Clever bod needed

walsi

Active Member
Joined
Dec 24, 2009
Messages
260
Location
north cornwall
Car
mercedes vito 120 CDI chipped and lowered
I might or might not have a problem with my vito 120. Had its first MOT the other day and when we came to check the emissions we had a hell of a job to get any type of reading out of the exhaust (ended up blocking the pipe up with rags). It was suggested that the pipe might be blocked so off i went home and removed the pipe as far back as the particulate filter. The first thing was loads of crap came running out but the other thing was when we started the car up it was almost silent untill i put it in gear when it got slightly louder. It then went quiet and sounded like it was running under water (best description). I made up a short straight through pipe and fitted it after the particulate filter and went for a blast to see if it made any difference, it smoked like you wouldnt believe for about 1/2 a mile but then cleared. On the way back it suddenly got very loud and then went quiet again and has remained like this ever since with the only difference being that you can really smell the cat now as it warms up. Is there some sort of valve in the exhaust that could be sticking or is there some other obvious thing that could be wrong that i have missed. Any help would be much appreciated

Cheers Martin
 
OP
OP
walsi

walsi

Active Member
Joined
Dec 24, 2009
Messages
260
Location
north cornwall
Car
mercedes vito 120 CDI chipped and lowered
With all the clever people on here someone must have an idea about this even if it is just a guess
 

kwakdonut

MB Enthusiast
Joined
Jul 22, 2006
Messages
2,744
Location
Highworth, Wiltshire
Car
Frod Mundano TDCi, Kawasaki z650
Can you give us all some more details? Current mileage? How the vehicle is used normally? Sounds like something is blocked - have you tried giving it an Italian Service?!
 

bouncer

Active Member
Joined
Sep 20, 2007
Messages
329
Sounds like a sticking ERG valve which had overloaded your Particulate filter, the filter needs regenerating. . . . a motorway dive (70 mph) to burn off the carbon thats blocking your filter will help. Short journey syndrome my guess.

sTeVe
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,691
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S205 C300
In 2008 there was a recall for the Vito 120 (ECU re-flash) to address an EGR problem. Make sure yours had it done - the ref is C141.
 
OP
OP
walsi

walsi

Active Member
Joined
Dec 24, 2009
Messages
260
Location
north cornwall
Car
mercedes vito 120 CDI chipped and lowered
Thankyou one and all, there is no record in the service history or any of the many receipts of anything other than main dealer services and some tyres, i will investigate further regarding the egr. Info is 50,000 miles, mostly motorway work and yes its driven hard quite often, it would be cruel not to :)
My suspicions were that something was blocked but when i split the pipe between the cat and filter it made no difference to the output which sort of ruled out it been the particulate filter and there are no rattles from the cat either so unless it is choked solid with something it doesnt appear to be that either.
The mystery continues
Many thanks for the input thus far, Martin
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,691
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S205 C300
I got nothing in writing after the recalls (the other one being for the spare wheel carrier). I'd have thought that a main dealer would automatically check the ECU software version, but it wouldn't hurt to get this confirmed.
 
OP
OP
walsi

walsi

Active Member
Joined
Dec 24, 2009
Messages
260
Location
north cornwall
Car
mercedes vito 120 CDI chipped and lowered
Thanks Bill i will do.
 

Users who are viewing this thread

Top Bottom