CLicking when car is started.

51ngh

New Member
Joined
Sep 18, 2015
Messages
4
Car
w209 clk 320
Hi All,

SO finally bought a clk w209 320 and i love it. It had some error messages on the dash which the dealer sorted (common coolant message which resulted in new radiator/fan assembly and sensor in washer bottle).


I now have this clicking sound when I turn the key in the ignition. The sound is coming from behind the centre vents it seems.
From doing the usual forum searches I believe its the "stepper arm" that is broken causing the clicking. It stops after 10/15 seconds. I have already tried the reset procedure (hold down recirculate and front windscreen heater buttons) however its still there.


Is there anyone in the West London area who is willing to help fix this. I can pay for your time, its just I'd rather go to someone who knows and appreciates these cars than a stealer who will charge me silly money!


I also have the door lock spring broken problem causing the passenger side to bounce up and down. Would also like to get this fixed whilst I'm at it!

Any suggestions help is welcome!
 

SPX

MB Club Veteran
SUPPORTER
Joined
Aug 29, 2010
Messages
16,321
Location
Yorkshire
Car
That one
Most people simply live with the clicking because I'm fairly certain the whole dashboard needs to come out to fix the fault.
 
OP
OP
5

51ngh

New Member
Joined
Sep 18, 2015
Messages
4
Car
w209 clk 320
ahh really?

I read in a few places if its the central one its not a whole dash out job?

Anyone have experience of this?
 

Stratman

MB Enthusiast
Joined
Jun 15, 2003
Messages
4,764
Location
Sunbury
Car
W203 C200 CDI '04Estate
The amount of dismantling depends on which of the many arms has failed. It can vary between minimal and dash out.

Putting the car on a STAR will tell you the culprit, hopefully the STARman will then be able to tell how difficult replacement will be.
 
OP
OP
5

51ngh

New Member
Joined
Sep 18, 2015
Messages
4
Car
w209 clk 320
ok thanks - do you know of any specialists in the west london area who can assist with this?
 

ShaunB

MB Enthusiast
SUPPORTER
Joined
Oct 14, 2013
Messages
1,081
Location
N.Ireland
Car
W213 Designo Hyacinth E63
ahh really?

I read in a few places if its the central one its not a whole dash out job?

Anyone have experience of this?
I had that one replaced on my old CLK55. It was the bottom half of the dash out.
 

Dave Richardson

Active Member
SUPPORTER
Joined
Oct 14, 2007
Messages
846
Location
Plymstock Plymouth
Car
C Class 220 Evo CDI and a W176 A class 180 cdi
Sounds very much like the problem is with the stepper motors, unfortunately it's most likely to be a dash out job & each motor is approx. £70
 

ShaunB

MB Enthusiast
SUPPORTER
Joined
Oct 14, 2013
Messages
1,081
Location
N.Ireland
Car
W213 Designo Hyacinth E63
Should have said, in my case the motor was fine, the series of plastic cogs/arms were the problem.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom