climate control

y13pmc

Member
Joined
May 4, 2011
Messages
37
Location
doncaster home of football
Car
e320
hi all i dont seem to be getting any heat fron climate control even when set to max heat any ideas regards pete
 

Matt H

Member
Joined
Jun 30, 2012
Messages
30
Location
Dorset
Car
C200 Kompressor
Any updates on this anyone? I've just experienced a similar problem in my car today. Climate control set to 26 but still blowing cold air and the only heat i'm getting is from the heated seats - Not pleasant at 5am when it's single figures outside!
My car is a 2003 CLK55 AMG
 

andy27168

MB Enthusiast
SUPPORTER
Joined
Nov 27, 2004
Messages
4,569
Location
Southampton
Car
1997 C230K, 1999 C43/55 AMG
Hi,
Sounds like a possible heater valve issue, if the heater doesnt kick out any heat.
 

zenman63

MB Enthusiast
SUPPORTER
Joined
Feb 8, 2010
Messages
2,263
Location
Warwickshire
Car
172 Slk 250 & Porsche 911 991.2 2018 Range Rover autobiography
Does sound like a heater valve
 

Matt H

Member
Joined
Jun 30, 2012
Messages
30
Location
Dorset
Car
C200 Kompressor
Thanks guys, I shall get this part looked at and hopefully that's all it is. Any idea on how much a new heater valve is? I did find a link showing how to replace this yourself but not sure I like the idea of doing this myself so will look to take to an indy to sort.
 

stevejh

New Member
Joined
May 27, 2009
Messages
5
Afternoon!

Any news on this, my aircon blows ice cold but never gets above tepid!

I've tried a/c off, still the same. I even had odd temperatures coming out the front vents, the opposite of what the temp dials were set to!

Since I bought the car in May it's been in and out the garage. Inc service I've spent nearly £1k on it (2004 C200 diesel)! I really don't want to take it back in anywhere...

Cheers
 

Users who are viewing this thread

Top Bottom