Clk 230k w208 speedo fault

Discussion in 'Electronics' started by dotmikes, Sep 5, 2016.

  1. dotmikes

    dotmikes New Member

    Messages:
    11
    Joined:
    Feb 23, 2016
    Car:
    Mercedes CLK 230K 2001
    Hi

    I have a fault with my instrument cluster.

    everything works fine apart from the lights (behind the speedo)that illuminate when the switch is turnt on.

    i have checked all fuses... under bonnet.. drivers side and the boot and they are working/not blown.

    intotal there are 4 bulbs that are ment to swith on behind the speedo, I cannot get the 2 larger ones to illuminate what so ever.. i have tested the bulbs and they are fine. but the 2 bulbs that are smaller to either side will not switch off.. they are always on no matter what, even if I remove the fuse that controls the dash!!

    I can only think that the speedo is faulty but hopefully I have missed something out that you guys can help me with!!

    thanks,
    Mike
    07969-156-077
     
  2. OP
    OP
    dotmikes

    dotmikes New Member

    Messages:
    11
    Joined:
    Feb 23, 2016
    Car:
    Mercedes CLK 230K 2001
    anything?

    :)
     
  3. OP
    OP
    dotmikes

    dotmikes New Member

    Messages:
    11
    Joined:
    Feb 23, 2016
    Car:
    Mercedes CLK 230K 2001
    i got a new one in the end.. all working
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.