Clk 270 wont start after new inlet manifold fitted

Discussion in 'Engine' started by srpj1, Apr 27, 2014.

  1. srpj1

    srpj1 Member

    Messages:
    36
    Joined:
    Nov 19, 2013
    Hi I've fitted new inlet manifold and had the diesel rail off , it's all back together now but won't start , any ideas ?
     
  2. Twistedmind

    Twistedmind Hardcore MB Enthusiast

    Messages:
    592
    Joined:
    May 30, 2013
    Location:
    Staffordshire
    Car:
    Mercedes E270 w211
    Possible air lock. Or fuel bleeding required

    Sent from my iPhone using MBClub UK
     
  3. OP
    OP
    srpj1

    srpj1 Member

    Messages:
    36
    Joined:
    Nov 19, 2013
    cool I have got fuel to injectors and when cracked off they leak fuel ! I read that maybe I need to fit an inline hand pump so I can build up the preasure ?
     
  4. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,314
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, MK1 Caddy, S500, etc
    Fill the fuel filter with fuel and keep cranking.
     
  5. WG M-B

    WG M-B Auhorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    1,898
    Joined:
    May 26, 2011
    Location:
    N/W london
    Car:
    C63 Wagon in black
    You need to get air out of the lift side of the system. If you fill the fuel filter, then pop the outlet pipe off the small slave pump on the engine ( there are directional arrows on the pump )
    Then crank until fuel flows out!
    Once the fuel is there put the pipe back in.
    Then she will fire within a few cranks
    Cracking off injectors will just drop the rail pressure and log a fault code
     
  6. mersum1es

    mersum1es Hardcore MB Enthusiast

    Messages:
    1,056
    Joined:
    Aug 9, 2012
    Location:
    Finland
    Car:
    W220, W210
    Is there air bubbles in clear pipes? Like above, needs lot of cranking if filter not filled. Double check that all injectors connectors are ok and in contact. Check CPS wires too.
     
  7. E270 Owner

    E270 Owner Hardcore MB Enthusiast

    Messages:
    1,672
    Joined:
    Dec 23, 2012
    Location:
    S E London
    Car:
    Anything I get my hands on.
    This ^

    Easy to forget to plug the crank position sensor back on after having the inlet manifold off .
     
    1 person likes this.
  8. OP
    OP
    srpj1

    srpj1 Member

    Messages:
    36
    Joined:
    Nov 19, 2013
    Hi the car has not got a slave pump but I'm going to fit slave pump on to section from filter to engine then fill the filter and see if it will draw fuel through ? Could this work ?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.